46

My newly deployed Ubuntu 20.04.4 LTS has already installed Firefox 80, but most videos in the web are not playable. One codec complains "No video formats available", while the other, for example, youtube, says that my browser can't play HTML5 videos.

What I've tried?

  • Reinstall the browser
  • Install the flash plugin(deprecated technology, I know)
  • Install the widevine extension. Followed instruction

These solutions didn't help me a lot: the top result reached is watching videos on the sites supporting flash content.

So, what should I do? Please, instruct me!

3 Answers 3

108

Bro, a solution for your problem takes no more than one line :)

sudo apt install ffmpeg

That's all! After restarting your firefox browser the changes are applied and the browser plays any video content you wish.

P.S. I lost 2 annoying days searching the web for solution, trying different approaches, rolling back changes, reinstalling browser and so on, and try to imagine my face when this single line appeared the solution.

10
  • 4
    works like a charm, thanx !
    – scraaappy
    Nov 16, 2020 at 13:55
  • 1
    Absolutely does not work. I get some permissions boilerplate that needs to be OK'ed, but one cannot Okay it. The open terminal just sits there uselessly.
    – KCinAZ
    Mar 23, 2021 at 15:19
  • 1
    Soooo sorry, this answer does work. I FORGOT you can get to OK by using TAB. My bad. I'll promote answer once the system unlocks. It works great and many thanks.
    – KCinAZ
    Mar 23, 2021 at 15:49
  • @KCinAZ Oh, I guess I know what are you talking about. While troubleshooting one problem(concerned with libreoffice) I also faced that strange menu which asked me to agree, but I didn't know how to do it. I was a newbie in using terminal in that moment, so I just pressed random buttons until it worked.
    – mathway
    Mar 23, 2021 at 15:50
  • Works for me too. TY @scraaappy! Apr 15, 2021 at 22:24
13

You may also try

sudo apt install ubuntu-restricted-extras

See here for what it installs.

5
  • Exactly the same problem as above. You cannot OK the dialog.
    – KCinAZ
    Mar 23, 2021 at 15:33
  • 3
    @KCinAZ Navigating within a shell dialogue box seems like a separate problem. Hopefully you figured it out by now using your keyboard keys (tab, shift+tab, arrows, space, enter, etc).
    – FNia
    Mar 24, 2021 at 19:58
  • Other pages suggested this too. It wanted 150MB disk space which I couldn't get back, or repeat. I recommend @mathway's ffmpeg and DRM method over this.
    – John
    May 1, 2021 at 23:52
  • 1
    I prefer to install sudo apt install ffmpeg. It's a more controlled and open-sourcy way.
    – morhook
    Sep 1, 2021 at 18:05
  • As with ffmpeg and libavcodec-extra, this also didn't work for me (Ubuntu 21.10).
    – user643722
    Apr 30, 2022 at 18:11
12

Just Open Terminal and paste:

sudo apt install libavcodec-extra -y

Restart Firefox and video playback will be working.

2
  • This works fine for me !! I am using Ubuntu 20.04.3 LTS. Jan 16, 2022 at 16:15
  • This is the correct answer. Mar 19, 2022 at 10:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .