0

I've recently installed Ubuntu 20.04.01 LTS on my Lenovo Yoga S740 with Intel Core i7-1065G7.

I noticed that my laptop is always hot (around 60 degrees CPU temp) and the fans make noise, along with heavy battery usage.

Upon further research, I noticed that the CPU frequency is always around 3.5 GHZ.

The governor is powersave. I tried lowering the max frequency using tlp (for example, to 2.0 GHz) and it always stays at max.

This behaviour also happens when running the Live USB.

Added the output to the commands:

/sys/devices/system/cpu/cpu0/cpufreq/scaling_driver:intel_pstate
/sys/devices/system/cpu/cpu1/cpufreq/scaling_driver:intel_pstate
/sys/devices/system/cpu/cpu2/cpufreq/scaling_driver:intel_pstate
/sys/devices/system/cpu/cpu3/cpufreq/scaling_driver:intel_pstate
/sys/devices/system/cpu/cpu4/cpufreq/scaling_driver:intel_pstate
/sys/devices/system/cpu/cpu5/cpufreq/scaling_driver:intel_pstate
/sys/devices/system/cpu/cpu6/cpufreq/scaling_driver:intel_pstate
/sys/devices/system/cpu/cpu7/cpufreq/scaling_driver:intel_pstate
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor:powersave
/sys/devices/system/cpu/cpu1/cpufreq/scaling_governor:powersave
/sys/devices/system/cpu/cpu2/cpufreq/scaling_governor:powersave
/sys/devices/system/cpu/cpu3/cpufreq/scaling_governor:powersave
/sys/devices/system/cpu/cpu4/cpufreq/scaling_governor:powersave
/sys/devices/system/cpu/cpu5/cpufreq/scaling_governor:powersave
/sys/devices/system/cpu/cpu6/cpufreq/scaling_governor:powersave
/sys/devices/system/cpu/cpu7/cpufreq/scaling_governor:powersave
/sys/devices/system/cpu/cpu0/cpufreq/affected_cpus:0
/sys/devices/system/cpu/cpu0/cpufreq/base_frequency:1300000
/sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq:3900000
/sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_min_freq:400000
/sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_transition_latency:0
/sys/devices/system/cpu/cpu0/cpufreq/energy_performance_available_preferences:default performance balance_performance balance_power power 
/sys/devices/system/cpu/cpu0/cpufreq/energy_performance_preference:balance_performance
/sys/devices/system/cpu/cpu0/cpufreq/related_cpus:0
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors:performance powersave
/sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq:3015807
/sys/devices/system/cpu/cpu0/cpufreq/scaling_driver:intel_pstate
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor:powersave
/sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq:3900000
/sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq:400000
/sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed:<unsupported>

Kernel version is 5.4.0-47-generic

8
  • Hmmm... I don't think this is actually a problem you can do anything about unless you undervolt and underclock in the BIOS. Highly unrecommended unless you are fully aware of the risks. 60C is actually not that hot for a CPU. The laptop is hot because of the hardware it uses. The CPU is a high power CPU (for a laptop) and can use up to 25w.
    – Nmath
    Commented Sep 10, 2020 at 7:05
  • Indeed, 60C is not that hot. The problem is that the CPU always stays at max frequency even when not doing anything (that leads to battery drain). There is something wrong with the frequency scaling.. maybe a bug in the kernel?
    – Alex
    Commented Sep 10, 2020 at 7:18
  • How are you monitoring this? This is normal, typical, intended behavior for the CPU to run at max frequency. What you should be concerned about for heat and battery usage is the % utilization.
    – Nmath
    Commented Sep 10, 2020 at 7:23
  • Let me elaborate, the CPU will typically ramp up to the max clock speed any time it has anything to do, including idle processes. Power draw is a product of clock speed, voltage, and CPU/thread usage. So when the CPU is not working hard, it will draw less power even though idle processes will still use the full speed of your CPU. (They are not throttled) -- Does your BIOS have an option to enable Intel Speedstep?
    – Nmath
    Commented Sep 10, 2020 at 8:03
  • Thanks for the info. No, my BIOS does not have Intel Speedstep option. By running the "powertop" utility for 10 minutes, the average CPU frequency for all cores is 3.4-3.6 GHz with CPU usage lower than 5%. The frequency never goes lower than 3.4 GHz. The fans are very noisy because of this and the laptop also heats. Lowering the CPU frequency using tlp to 2 - 2.5 GHz prevents heating and fan noise at the cost of performance. It only happens with Ubuntu, Windows 10 works perfectly.
    – Alex
    Commented Sep 10, 2020 at 9:09

1 Answer 1

0

I managed to solve the issue (not sure how) by deleting all commands in "Startup Applications" and also installed CPU power management Gnome extension.

That seemed to do the trick.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .