I tried to install Postman on Ubuntu 18.04.5 LTS using snap and I got this error :

sudo snap install postman
erreur : cannot install "postman": Post
          https://api.snapcraft.io/v2/snaps/refresh: dial tcp: lookup
          api.snapcraft.io: no such host

Also tried to download the bin from here, but does not work too.

  • the problem seems to be related to dns resolution – doom Sep 9 '20 at 19:15

Could be a DNS Issue.

To fix it, you can explicitly set DNS addresses. Here after an example with OpenDNS (on Elementary OS 5.1, but should be practically the same thing on other distributions or flavours)

  • Go to System Settings > Network & Wireless > Network

  • On your current connection, push the "Advanced Settings" then select the IPV4 settings tab

  • Enter new IP addresses of DNS server, in this case :, and save.

It worked for me. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.