0

I'm attempting to install extensions that will be readily available for new users on the same machine. I'm using Ubuntu 20.04 Gnome Desktop Environment, Gnome-Tweaks tool, and I have enabled shell extensions. Ideally, I'd also like the extensions to have the right settings, identical to the ones I've set on my user.

I know how to install extensions via Firefox as per this guide How do I install and manage GNOME Shell extensions?.

The problem is these extensions will only be available to my user, of course.

I'm no expert using Ubuntu, but I have tried a few different things.

Installing extensions to /usr/share/gnome-shell/extensions/ folder

Excuse the lack of links, but I can't find where I found this information now, where it instructs users to install extensions to the /usr/share/gnome-shell/extensions/ folder, by simply copying the contents of ~/.local/share/gnome-shell/extensions/ (assuming that the extensions you wish to install are installed here, the user installed extensions).

In other words:

  1. Go to ~/.local/share/gnome-shell/extensions/ where you'll find your extensions, the folders will look something like /some-extension-name@creator.mail.com.
  2. Copy this folder to /usr/share/gnome-shell/extensions/ and keep the same name, by doing something like:
    sudo cp -a ~/.local/share/gnome-shell/extensions/some-extension-name@creator.mail.com /usr/share/gnome-shell/extensions/some-extension-name@creator.mail.com 

This didn't quite work for me, upon doing this, I tried to create a new user via Settings. The user was successfully created but upon logging in for the first time and checking the Gnome Tweaks tool, the extensions that I attempted install weren't visible.

Does anyone have a solution?

2

1 Answer 1

0

I don't know if you need still to fix this but maybe it is usefull for someone else. It could be a problem with permissions. Check if the permissions on the copied extensions folders are the same as on the default extensions folders. Also check if all users have at least read permissions on all files inside the extension folder. I had the same problem and fixed it with chmod 644 on the metadata.json file in the extension folder. This gives read/write to the owner, read to the group and read to public.

1
  • I agree. @Hugo, instead of cp -a, use sudo cp -r ~/.local/share/gnome-shell/extensions/some-extension-name@creator.mail.com /usr/share/gnome-shell/extensions/.
    – Enterprise
    Jul 12, 2021 at 14:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.