1

How do I disable the location bubble in gnome-maps? I'm using i3 and don't have most of the gnome-settings packages installed, but it seems like even if you disable location services in gnome, the blue bubble still appears.

I've tried sudo sed -i s/true/false/g /etc/geoclue/geoclue.conf so that gnome-maps doesn't have access to geoclue, but geoclue still starts up and reports a location. I've even tried chmod 000 /usr/libexec/geoclue with killall -9 /usr/libexec/geoclue and the location still appears.

Is there a gconf setting that lets me disable location entirely in gnome-maps? I'm on a desktop machine in my apartment. It's not going to move. I really don't need a dot to tell me where I am.

Screenshot of Gnome-maps

2
  • What is gsettings get org.gnome.system.location enabled? Maybe it is based on your internet connection? (gitlab.freedesktop.org/geoclue/geoclue/-/wikis/home/). Try using dconf editor>/org/gnome/system/location/ or disable the above schema. Sep 9, 2020 at 7:19
  • @kortewegdevries org.gnome.system.location is set to false However, I restarted gnome-maps and it appears I no longer have a location. I believe it's likely due to disabling execution on the geoclue executable.
    – djsumdog
    Sep 9, 2020 at 18:31

1 Answer 1

1

Running the command sudo systemctl mask geoclue.service in Terminal works for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .