0

I have a HP Color Laser Jet Pro MFP M477fdn, and am trying to print on both sides on Ubuntu 18.04.

If I open any app (pdf reader, or a pdf through Chrome), I can select the "print on both sides" option.

But when I hit print, it just prints one-sided.

NOTE:

  • If I print using a Windows laptop, it supports 2-sided just fine.
  • If I print a pdf from Google Drive using my android phone, that also works.
  • If I visit the CUPS admin page, I can see that 2-sided printing is on.

I assume this is an issue with my local drivers, but I don't think there's a specific driver I can install, other than what CUPS discovers for me.

How might I get this to work?

EDIT: Here's the output of dpkg -l hplip - note this is AFTER the fix in the solution below, so no clue what this would have looked like before:

$ dpkg -l hplip
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                          Version                     Architecture                Description
+++-=============================================-===========================-===========================-===============================================================================================
ii  hplip                                         3.17.10+repack0-5           amd64                       HP Linux Printing and Imaging System (HPLIP)
5
  • 3
    Does this answer your question? How to install latest HPLIP on my Ubuntu to support my HP printer and/or scanner?
    – N0rbert
    Sep 9, 2020 at 8:46
  • Hey user2671688! What's the ouput of dpkg -l hplip? Please paste the output in your question. Sep 9, 2020 at 11:42
  • It's currently 3.17.10+repack0-5 - While the installer was running, it did say: "This installer will install HPLIP version 3.20.6 on your computer." - interesting. Sep 9, 2020 at 12:38
  • The output will generally be a bit lengthier. Can you please post the full output in the question? Sep 9, 2020 at 16:28
  • added the output; obviously, this is post-following-the-instructions-below. Sep 9, 2020 at 23:58

1 Answer 1

0

Try this:

Download the file to ~/Dowloads

https://sourceforge.net/projects/hplip/files/hplip/3.20.6/hplip-3.20.6.run/download?use_mirror=nchc

Open a terminal and remove the previously installed version:

sudo apt remove hplip*

Cd to the location where the installer was downloaded.

cd ~/Downloads
    

To install run this command:

sh hplip-3.20.6.run

Select the install mode Automatic, enter an a

Ensure the installer detected the correct Linux distribution.

Enter Your root/Superuser User Password.

The installer will now detect what dependencies your system will need to install before installing HPLIP

If your system is missing any dependencies they are now downloaded and installed.

./configure prepares HPLIP for install as well as your system is verified to have all the required dependencies for HPLIP.

'make' is then executed. Make compiles ("builds") HPLIP for your system.

'make install' is the actual install procedure, this step is where HPLIP is actually being installed to your system.

Use 'hp-setup' to configure your printer.

The first step is to select the printer connection type.

Next the setup tool will display printers detected.

Select the PPD file to be Used for Your printer, usually you will want to select the recommended PPD file.

Click "AddPrinter" to complete the printer setup process.

13
  • Thank you! That worked great. The only snag I hit: Looks like hp-systray was running, so the setup died at the end, and resulted in me having to go into cups myself and updating some default settings. Strangely, I could print double-sided, but document reader said "some fields have conflicts". :) Anyway, once I enabled the right flags in CUPS, those errors went away too. Thanks again! Sep 9, 2020 at 1:31
  • Hey kyodake! If I'm not wrong, HPLIP is pre-installed with Ubuntu. developers.hp.com/hp-linux-imaging-and-printing/install/… "Most current Linux distributions include HPLIP pre-installed when the operating system was installed." So, why should user2671688 install HPLIP again? Sep 9, 2020 at 11:34
  • @technastic: Don't install it again. Update it to the latest version.
    – kyodake
    Sep 9, 2020 at 12:23
  • The installer handles uninstalling it as part of its work. Per my comment on my original question, running dpkg -l hplip still shows 3.17.10+repack0-5 instead of the expected 3.20.6. That said, while setting this printer up initially, I had all sorts of problems ("not accepting jobs" until I installed through CUPS directly, then getting "empty PPD file" errors with CUPS, etc. - eventually it worked but config like double-sided was ignored... reinstalling HPLIP did the trick, even though the version number seems to be a lie. :) Sep 9, 2020 at 12:42
  • @user2671688 How did you set up the printer before seeing this answer? I'm not sure if the newly installed HPLIP will remove the pre-installed HPLIP. Sep 9, 2020 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.