0

I installed Ubuntu v20.04 on my Dell Inspiron 7586 that has come with Intel Dual-Band Wireless 7260 Adapter but when I use the OS as 'Try Ubuntu' everything was working fine except the WiFi which was repeatedly enabling and disabling recursively. I thought installing might resolve the problem but it stayed the same even after installing the OS to the drive partition.

I even tried to figure out if their could be a driver update available at 'Additional Drivers' but except NVIDIA's MX150 driver package nothing was there.

I tried to find the solution over internet for doing it manually as there are no option available like Driver Manager in Windows or Mac that can find the precise driver for the specific hardware component interface. I got the driver from Intel's Support website for Linux https://www.intel.com/content/www/us/en/support/articles/000005511/network-and-i-o/wireless.html, I downloaded, extracted into /lib/firmware, restarted system but nothing changed.

I thought there might be a driver file inside /lib/firmware that OS recognized as its appropriate driver instead of adapting the right one (i.e in my case the device driver for Dual band 7260 states as iwlwifi-7260-16) so I deleted all the related iwlwifi-* (* indicates all files with prefix iwlwifi-) and only installed the driver file 'iwlwifi-7260-16.ucode' in /lib/firmware but it also didn't help but this time, the WiFi was totally disappeared.

I also tried by downgrading to 19.04, 18.14 and 18.04 version of Ubuntu Distro but the problem remains the same.

The terminal command for sudo lshw -C network showed this result.

[sudo] password for arslan: 
  *-network UNCLAIMED       
       description: Network controller
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 6b
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:91100000-91101fff

Here it states as UNCLAIMED, which I tried to figure online for the solution but found nothing. Unfortunately my laptop which I have currently installed Ubuntu and caught with this issue has no Ethernet and using a WiFi dongle to use internet on my device. With Wireless dongle, the internet works fine.

0

Your wireless device shows as UNCLAIMED because, although the correct driver loads, it is no longer able to find the correct firmware file. You deleted it.

Please do:

sudo apt update
sudo apt install --reinstall linux-firmware

Reboot. I suspect that your wireless is working, albeit disconnecting all too frequently.

Your wireless may be dropping because of power management; that is, the feature where the card partially powers down to save battery power during periods of inactivity and then, ideally, powers back up seamlessly when activity resumes. Let's disable pwer saving to see if it helps. From the terminal:

sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/*

Your wireless may be dropping because the channel to which it was connected has suddenly changed.

Please check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I recommend a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred.

Your wireless may be dropping because there are two wireless access points with the same name and password. This is typical when you have a 2.4 gHz segment and a 5 gHz segment of the same router. Your wireless may be roaming, looking for a better connection. If this is the case, I suggest that you rename the access points; something like myrouter2.4 and myrouter5.

After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

sudo nano /etc/default/crda

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

5
  • Thank you for reaching out chili555. I have done nothing at my end initially. I mentioned earlier that I chose 'Try Ubuntu' initially and I found that problem pertained from that time even installing it to a drive partition. Another thing adding to all that concern, I also changed the OS distro to check if I found a solution elsewhere. I tried Linux Mint, Elementary OS and also Fedora but all had the same problem stating the same issue with regards to 'UNCLAIMED' status of the network card. – Mohammad Arslan ud Din Sep 9 '20 at 17:36
  • But yeah, I checked the wireless card status using lshw -C network where it showed DISABLED other than UNCLAIMED but the behavior was same all the time. But I will definitely try the method you just mentioned here. I hope if that shall work out. – Mohammad Arslan ud Din Sep 9 '20 at 17:37
  • Is this a dual boot with Windows? Please see: wireless.wiki.kernel.org/en/users/drivers/… – chili555 Sep 9 '20 at 21:24
  • Yes, okay I will go through this thread. Lets see if it will resolve the problem. I tried the solution you posted earlier. It didn't work for me. I hope it does. Thanks again – Mohammad Arslan ud Din Sep 10 '20 at 8:43
  • I tried disabling the fast boot feature in Power Option of Windows as I installed the Ubuntu as Dual boot but nothing happened. The behavior is still the same. – Mohammad Arslan ud Din Sep 10 '20 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.