I have a nvidia graphics card, and Unity 3D will not load. When I log into a 3D session, I see my wallpaper. I am able to right click. How can I fix this?

  • Not all Nvidia cards can run Unity. Which Nvidia card model do you have? – mikewhatever Apr 29 '12 at 0:44
  • Welcome to Ask Ubuntu! This question should instead be filed as a bug report, thanks! Instructions here. – Jorge Castro Apr 30 '12 at 1:59

I had exactly the same problem. What I had to eventually do is to log out of my account by using Ctrl-Alt-Del, choose Unity 2D then log in again. I tried with different hardware drivers and different user interfaces, but this is the only one that works.

The support for my GeForce 6100 nForce 405 (as the system detects it) has degraded each of the last two releases. With each of the past two releases my computer was unuseable at all until I fixed the video support. WarZone 2100 worked find before 11.10, then it got slower. With 12.04 it is so slow (it takes a full minute for the title screen to come up) that it is impractical to play. At this rate, my graphics card won't be supported at all with 12.10.

  • Well the 2D interface works perfectly fine for me, it's just the 3D one that's causing problems. I do have another driver option, but last time I tried to install it, I couldn't access Ubuntu at all (out of range error). So I'm kinda unsure what to do now – kedarv Apr 29 '12 at 2:16
  • I have a machine with onboard GeForce 6150 which is having the same problem. Unity 3D worked great in 11.10 though. – aap Apr 30 '12 at 13:13
  • I'm not sure if the video card drivers have anything to do in this case; although many people recommends upgrading. I have an ATI Radeon HD5750 and Unity worked well with 11.10, until I upgraded to 12.04. Please make sure you haven't "customized" your compiz settings before the upgrade (that was my case). I found that discarding all my custom compiz settings was enough to get everything working as a fresh install because Compiz crashed on my profile, but not with the Guest account where Unity worked perfectly. – Simón Apr 30 '12 at 23:03

Compiz seems to be crashing, causing the whole UI to fail.

  1. Create a folder using the right click menu.
  2. Double click the folder.
  3. Browse to Filesystem -> /usr/bin and open a terminal (I used xterm)
  4. sudo apt-get install unity-2d
  5. logout (ctrl-alt-del)
  6. select unity 2d to log back in


  • Unity 2D already works, should I reinstall 3D? – kedarv Apr 29 '12 at 13:53

Did it work some time i.e. before upgrading to 12.04? If so, you might probably want to look at Missing launcher after 12.04 upgrade.

  • The compiz file doesn't exist – kedarv Apr 29 '12 at 16:58
  • Unity is a plugin for Compiz; so if you don't have Compiz, I don't know how are you attempting to load it. Please, provide more information about your environment, how did you install 12.04 (fresh install or upgrade?), and if Unity used to work on your system with previous version of Ubuntu, etc... Have you tried with the Guest account? – Simón Apr 30 '12 at 16:09

I am having the same problem, nothing I have tried seems to be working either. I think it is a bug in the video card driver. We will have to wait for a new driver in order to be able to use 3d. Gnome 3d also does not work. From the login screen I can select unity 2d or gnome 2d and that seems to work fine, although I really like Gnome 3d. Frustrating. I may downgrade back to 11.10 if this is not fixed soon.


I had the same problem. Back then I had solved problem by rolling back to NIVIDIA version 295.33 (current ver 295.40) It worked for me until I did a system update. I lost my graphical interface after updating. Hope this solution might help you.

check out this thread - Unity 3d no longer works after installing 12.04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.