I usually use two keyboard layout, plain English (US), and Englis (US, intl. with dead keys) in order to type ' and press e, to make this: é.

It worked in many distributions for many years, now on a fresh installation of Ubuntu 18.04.5 I have problems. The layout lntl. with dead keys work as the plain US layout: I can not type é.

Even the Englis (US, intl. with AltGr dead keys) does not work properly. I obtain é by pressing AltGr+e, but if press AltGr+' followed by e I obtain 'e.

I do not wont to use the compose key, neither AltGr, I would like to obtain the standard behavior of English (US, intl. with dead keys).

  • if you press AltGr+' together then e you get ê – User24601 Sep 8 at 9:29
  • Thinking of bug #1890875. Did you relogin or reboot after having added English (US, intl. with dead keys)? – Gunnar Hjalmarsson Sep 8 at 11:34
  • thanks @GunnarHjalmarsson, the layout switch correctly. I found that English (UK, intl. with dead keys) work ad expected, so most probably there is a bug in English (US, intl. with dead keys). – mox Sep 9 at 8:51
  • The latter layout works for me on 18.04, so I don't think it's a problem with the layout itself. Bug #1573755 comes to mind. – Gunnar Hjalmarsson Sep 9 at 9:46

Thanks to @GunnarHjalmarsson for pointing me to Bug#1573755. Removing ~/.xinputrc has solved the problem for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.