3

I have a large amount of password protected files in a zip archive that I created in Ubuntu 18.04 or maybe even earlier. In Ubuntu 18.04 LTS I can extract the password protected files from the zip archive without any problems.

Now I have installed Ubuntu 20.04 on a new partition, but when I boot on that and try to extract files from the password protected zip archive I get an error message. This is not very reassuring!

It fails whether I just click on the file (inside the zip archive) or I right-click it and choose 'extract' from the menu. In the latter case it DOES ask me for a password, but still fails reading the file.

In both cases the error message is: "An error occurred while extracting files". Any help would be much appreciated. Thank you.

NB: An alternative would be to extract all files in 18.04 and try to password protect them in a new archive in 20.04. Could that be done?

2
  • 1
    OK... I ended up extracting all password protected files from the zip archive in Ubuntu 18.04 and then compress them in a new password protected zip file in Ubuntu 20.04 - see askubuntu.com/questions/1273794/… . But I still find it a bit shocking that 20.04 cannot read the password protected files from 18.04!!!
    – Henrik R.
    Sep 9 '20 at 15:00
  • Yes today this also happened to me. It's just crazy.
    – Redu
    Apr 1 at 11:22
0

After upgrading to ubuntu 20.04, I had the same issue. I got the error "An error occurred while extracting files" while trying to extract a password protected zip file.

After installing p7zip-full:

sudo apt install p7zip-full

The same archive manager could extract the files without issue.

WARNING: @Henrik R. warns that after installing he couldn't extract password protected files anymore that he'd already made on ubuntu 20.04. He coud again after removing p7zip-full

$ sudo apt remove p7zip-full
4
  • That was a terrible suggestion! After that install I can no longer extract files from the password protected zip files I had to create on Ubuntu 20.04!! But luckily "$ sudo apt remove p7zip-full" solved it!
    – Henrik R.
    Jul 16 at 12:15
  • Thanks for the info @Henrik R. I didn't run into that issue because I hadn't created any password protected zip files under Ubuntu 20.04 yet. Of course you could use p7zip to extract old zip files, then uninstall, then zip again with the default zip function in ubuntu 20.04 Perhaps there's also a way that works well with all types of password protected zip files.
    – Ciske
    Jul 16 at 12:23
  • worked for me! +1
    – Viter Rod
    Sep 19 at 1:02
  • Great! Hit the up-vote button on this question to let others know (at a glance) that it worked for you. Top left of the question :)
    – Ciske
    Sep 19 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.