4

I can only get the update which I need since it fixes issues I've already run into as an .exe file. How do I install it from Ubuntu? My notebook is a HP Probook 440 G5.

1
  • What is the problem using the 'fwupdmgr' utility? I use it on Ubuntu, and exe is for Windows.
    – Mahler
    Feb 20, 2023 at 19:52

2 Answers 2

7

You're not going to be able to install it from the EXE file directly. Although WINE can run some Windows programs, it certainly is not going to support the low-level calls that the EXE would perform to initiate the update.

You have a couple options:

  • Many OEMs include a feature in the BIOS which lets the BIOS update itself from the update file on a USB flash drive. You might check to see if your BIOS supports this.
  • You might try booting a live Windows PE environment to run the update file from there.
  • Install a full copy of Windows 10 temporarily to a USB hard drive, and install from there
  • If you're adventurous you could try unpacking the actual BIOS ROM file from the EXE and flashing it directly to the BIOS EMMC block with dd, but I wouldn't really recommend that.
4
  • Thing is I CAN update from BIOS but it needs a BIN file which apparently can be extracted from the .exe using some dodgy software in Windows. Can I do this on Linux? Advanced wizardry?
    – H3R3T1K
    Sep 7, 2020 at 18:41
  • @H3R3T1K If it's a self-extracting exe file, then 7-zip (an open source not dodgy program) on Windows can usually unpack it. However, you don't have a Windows install at the moment to run 7-zip, so you might want to take a look here and see if you can have any luck :) Sep 7, 2020 at 18:51
  • 1
    7zip on my Windows machine did the trick. Inside the .exe there were instructions in a HTML file on how to name folders and the file itself on the USB. Worked flawlessly. Thanks a bunch!
    – H3R3T1K
    Sep 8, 2020 at 5:57
  • 7-zip is available for Linux as well. Try installing the package "p7zip-full". You can then manage 7-zip compressed files just with the standard "Archives" application.
    – raj
    Sep 8, 2020 at 10:51
1

I had the same problem with LENOVO laptop and I managed to solve it by following this procedure. Steps 1,2 and 3 were done on my desktop.

  1. I downloaded the firmware update from the manufacturer's support (LENOVO in my case). Since my laptop's firmware upgrades are not included in vendors' lists, I downloaded the version for Windows 10 (as my desktop's OS), that is an 'exe' file.
  2. I downloaded the Windows OS from Microsoft site by downloading the tool under "Create Windows 10 installation media", with which I created a win10.iso file and saved it on my hard disk.
  3. I downloaded Hasleo's WinToUSB tool, with which I created a USB Windows To Go on a 32GB flash USB stick from above win10.iso file. The way that free version filled the necessary fields worked OK for me. You will not miss the instructions. The tool's interface is great. Sooo, the tool installed the OS on the flash stick, leaving 512MB free space. I then copied Lenovo's 'exe' file to the stick's \Users\Default\Documents folder.
  4. I booted the laptop from the USB stick. I had to complete the installation of the Windows 10 OS. I named the user 'Default'. (And it worked!)
  5. When the operation was completed, I run Lenovo's 'exe' file and updated BIOS firmware. (The USB Windows OS required an external mouse, so don't panic if you can't use the touchpad.)
  6. When the computer restarted from the UBUNTU SSD, I checked the firmware's version (from a terminal) with command sudo dmidecode -s bios-version to verify that the work was properly done. (It was.)
1
  • @Mahler In my case, fwupdmgr did not get any updates for my firmware. May be because, my laptop is not one that LENOVO provides a Linux support.
    – user1623201
    Feb 20, 2023 at 21:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .