2

I have a system that is dual booted with Windows 10 and Ubuntu 20.04. I have some partitions that Win10 automatically has bitlocker enabled, therefore i cannot read or write from Ubuntu.

I followed this guide to try to decrypt and mount the drives: https://www.linuxuprising.com/2019/04/how-to-mount-bitlocker-encrypted.html

Under windows, i have managed to find my Bitlocker key, let's say it's this:

123123-123123-123123-123123-123123-123123-123123-123123

And let's assume that the encrypted partition is

/dev/nvme0n1p2

I have created these two directories:

sudo mkdir -p /media/bitlocker
sudo mkdir -p /media/bitlockermount

I therefore issued this command to decrypt the drive:

sudo dislocker /dev/nvme0n1p2 -u 123123-123123-123123-123123-123123-123123-123123-123123 -- /dev/nvme0n1p2

But i get this error:

[CRITICAL] None of the provided decryption mean is decrypting the keys. Abort.
[CRITICAL] Unable to grab VMK or FVEK. Abort.

I also tried supplying the password without the '-'

1 Answer 1

0

Try using the -u flag instead of -p, for recovery_password vs user_password. That worked for me. I believe the 48-digit number that's auto-stored in your MS account is the recovery key. Also, with hyphens.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .