0

I can't print at all HP Deskjet 3630 wirelessly or usb HELP!! I've tried all I know. I was printing fine. I need to print badly. I have reloaded Ubuntu also to no avail. have tried different solutions posted nothing works. says cups-pki-expired

here is my info:

mike@mike-HP-Pavilion-Notebook:~$ sudo apt install hplip
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
hplip-data libhpmud0 libimagequant0 libsane-hpaio printer-driver-hpcups
printer-driver-postscript-hp python3-olefile python3-pil python3-renderpm
python3-reportlab python3-reportlab-accel
Suggested packages:
hplip-doc hplip-gui python3-notify2 python-pil-doc python3-pil-dbg
python3-renderpm-dbg python3-egenix-mxtexttools python-reportlab-doc
The following NEW packages will be installed:
hplip hplip-data libhpmud0 libimagequant0 libsane-hpaio
printer-driver-hpcups printer-driver-postscript-hp python3-olefile
python3-pil python3-renderpm python3-reportlab python3-reportlab-accel
0 upgraded, 12 newly installed, 0 to remove and 0 not upgraded.
Need to get 8,943 kB/9,304 kB of archives.
After this operation, 21.8 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://us.archive.ubuntu.com/ubuntu focal/main amd64 hplip-data all 3.20.3+dfsg0-2 [6,427 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu focal/main amd64 libhpmud0 amd64 3.20.3+dfsg0-2 [107
kB]
Get:3 http://us.archive.ubuntu.com/ubuntu focal/main amd64 libsane-hpaio amd64 3.20.3+dfsg0-2
[126 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu focal/main amd64 printer-driver-hpcups amd64
3.20.3+dfsg0-2 [266 kB]
Get:5 http://us.archive.ubuntu.com/ubuntu focal/main amd64 libimagequant0 amd64 2.12.2-1.1 [31.4
kB]
Get:6 http://us.archive.ubuntu.com/ubuntu focal/main amd64 python3-reportlab-accel amd64 3.5.34-
1ubuntu1 [19.4 kB]
Get:7 http://us.archive.ubuntu.com/ubuntu focal/main amd64 python3-reportlab all 3.5.34-1ubuntu1
[546 kB]
Get:8 http://us.archive.ubuntu.com/ubuntu focal/main amd64 hplip amd64 3.20.3+dfsg0-2 [204 kB]
Get:9 http://us.archive.ubuntu.com/ubuntu focal/main amd64 printer-driver-postscript-hp amd64
3.20.3+dfsg0-2 [1,122 kB]
Get:10 http://us.archive.ubuntu.com/ubuntu focal/main amd64 python3-olefile all 0.46-2 [33.7 kB]
Get:11 http://us.archive.ubuntu.com/ubuntu focal/main amd64 python3-renderpm amd64 3.5.34-
1ubuntu1 [60.4 kB]
Fetched 8,943 kB in 5s (1,936 kB/s)
Selecting previously unselected package hplip-data.
(Reading database ... 198951 files and directories currently installed.)
Preparing to unpack .../00-hplip-data_3.20.3+dfsg0-2_all.deb ...
Unpacking hplip-data (3.20.3+dfsg0-2) ...
Selecting previously unselected package libhpmud0:amd64.
Preparing to unpack .../01-libhpmud0_3.20.3+dfsg0-2_amd64.deb ...
Unpacking libhpmud0:amd64 (3.20.3+dfsg0-2) ...
Selecting previously unselected package libsane-hpaio:amd64.
Preparing to unpack .../02-libsane-hpaio_3.20.3+dfsg0-2_amd64.deb ...
Unpacking libsane-hpaio:amd64 (3.20.3+dfsg0-2) ...Selecting previously unselected package printer-driver-hpcups.
Preparing to unpack .../03-printer-driver-hpcups_3.20.3+dfsg0-2_amd64.deb ...
Unpacking printer-driver-hpcups (3.20.3+dfsg0-2) ...
Selecting previously unselected package libimagequant0:amd64.
Preparing to unpack .../04-libimagequant0_2.12.2-1.1_amd64.deb ...
Unpacking libimagequant0:amd64 (2.12.2-1.1) ...
Selecting previously unselected package python3-pil:amd64.
Preparing to unpack .../05-python3-pil_7.0.0-4ubuntu0.1_amd64.deb ...
Unpacking python3-pil:amd64 (7.0.0-4ubuntu0.1) ...
Selecting previously unselected package python3-reportlab-accel:amd64.
Preparing to unpack .../06-python3-reportlab-accel_3.5.34-1ubuntu1_amd64.deb ...
Unpacking python3-reportlab-accel:amd64 (3.5.34-1ubuntu1) ...
Selecting previously unselected package python3-reportlab.
Preparing to unpack .../07-python3-reportlab_3.5.34-1ubuntu1_all.deb ...
Unpacking python3-reportlab (3.5.34-1ubuntu1) ...
Selecting previously unselected package hplip.
Preparing to unpack .../08-hplip_3.20.3+dfsg0-2_amd64.deb ...
Unpacking hplip (3.20.3+dfsg0-2) ...
Selecting previously unselected package printer-driver-postscript-hp.
Preparing to unpack .../09-printer-driver-postscript-hp_3.20.3+dfsg0-2_amd64.deb
...
Unpacking printer-driver-postscript-hp (3.20.3+dfsg0-2) ...
Selecting previously unselected package python3-olefile.
Preparing to unpack .../10-python3-olefile_0.46-2_all.deb ...
Unpacking python3-olefile (0.46-2) ...
Selecting previously unselected package python3-renderpm:amd64.
Preparing to unpack .../11-python3-renderpm_3.5.34-1ubuntu1_amd64.deb ...
Unpacking python3-renderpm:amd64 (3.5.34-1ubuntu1) ...
Setting up python3-renderpm:amd64 (3.5.34-1ubuntu1) ...
Setting up python3-olefile (0.46-2) ...
Setting up hplip-data (3.20.3+dfsg0-2) ...
Setting up printer-driver-postscript-hp (3.20.3+dfsg0-2) ...
Setting up python3-reportlab-accel:amd64 (3.5.34-1ubuntu1) ...
Setting up libimagequant0:amd64 (2.12.2-1.1) ...
Setting up libhpmud0:amd64 (3.20.3+dfsg0-2) ...
Setting up libsane-hpaio:amd64 (3.20.3+dfsg0-2) ...
Setting up python3-pil:amd64 (7.0.0-4ubuntu0.1) ...
Setting up python3-reportlab (3.5.34-1ubuntu1) ...
Setting up printer-driver-hpcups (3.20.3+dfsg0-2) ...
Setting up hplip (3.20.3+dfsg0-2) ...
Creating/updating hplip user account...
Processing triggers for libc-bin (2.31-0ubuntu9) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for dbus (1.12.16-2ubuntu2.1) ...
Processing triggers for cups (2.3.1-9ubuntu1.1) ...
mike@mike-HP-Pavilion-Notebook:~$ hp-check
Saving output in log file: /home/mike/hp-check.log
HP Linux Imaging and Printing System (ver. 3.20.6)Dependency/Version Check Utility ver. 15.1
Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.
Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode
will check both of the above cases (both compile- and run-time dependencies).
Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION
Status Types:
OK
MISSING
- Missing Dependency or Permission or Plug-in
INCOMPAT - Incompatible dependency-version or Plugin-version
warning: ubuntu-20.04 version is not supported. Using ubuntu-19.10 versions dependencies to verify
and install...
---------------
| SYSTEM INFO |
---------------
Kernel: 5.4.0-45-generic #49-Ubuntu SMP Wed Aug 26 13:38:52 UTC 2020 GNU/Linux
Host: mike-HP-Pavilion-Notebook
Proc: 5.4.0-45-generic #49-Ubuntu SMP Wed Aug 26 13:38:52 UTC 2020 GNU/Linux
Distribution: ubuntu 20.04
Bitness: 64 bit
-----------------------
| HPLIP CONFIGURATION |
-----------------------
HPLIP-Version: HPLIP 3.20.6
HPLIP-Home: /usr/share/hplipwarning: HPLIP-Installation: Auto installation is not supported for ubuntu distro 20.04 version
Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.
[hplip]
version=3.20.6
[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip-3.20.6
html=/usr/share/doc/hplip-3.20.6
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=no
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=no
fax-build=no
dbus-build=no
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.20.6
restricted-build=no
ui-toolkit=no
qt3=no
qt4=no
qt5=no
policy-kit=no
lite-build=no
udev_sysfs_rules=nohpcups-only-build=no
hpijs-only-build=no
apparmor_build=no
class-driver=yes
Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory
Current contents of '~/.hplip/hplip.conf' file:
[installation]
date_time = 09/06/20 17:01:01
version = 3.20.6
<Package-name>
<Package-Desc>
<Status> <Comment>
<Required/Optional> <Min-Version> <Installed-Version>
-------------------------
| External Dependencies |
-------------------------
error: cups
CUPS - Common Unix Printing System
REQUIRED
1.1
-
INCOMPAT 'CUPS may not be installed or not running'
gs
GhostScript - PostScript and PDF language interpreter and previewer REQUIRED
7.05
9.50
OK
-
xsane
xsane - Graphical scanner frontend for SANE
OPTIONAL
0.9
0.999
OK
-
scanimage
scanimage - Shell scanning program
OPTIONAL
1.0
1.0.29
OK
-
dbus
DBus - Message bus system
REQUIRED
-
1.12.16
OK
-
policykit
PolicyKit - Administrative policy framework
OPTIONAL
-
0.105
OK
-
network
network -wget
OPTIONAL
-
1.20.3
OK
-
avahi-utils
avahi-utils
OPTIONAL
-
0.7
OK
-
------------------------
| General Dependencies |
------------------------
libjpeg
OK
-
cups-devel
-
OK
cups-image
-
OK
libjpeg - JPEG library
REQUIRED
-
-
CUPS devel- Common Unix Printing System development files REQUIRED
-
CUPS image - CUPS image development files
REQUIRED
-
-
-libpthread
libpthread - POSIX threads library
REQUIRED
-
b'2.31'
OK
-
libusb
libusb - USB library
REQUIRED
-
1.0
OK
-
sane
SANE - Scanning library
REQUIRED
-
-
OK
-
sane-devel
SANE - Scanning library development files
REQUIRED
-
-
OK
-
libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED
5.0.9
5.8
OK
-
libcrypto
libcrypto - OpenSSL cryptographic library
REQUIRED
-
1.1.1
OK
-
python3X
Python 2.2 or greater - Python programming language
REQUIRED
2.2
3.8.2
OK
-
error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications
OPTIONAL
-
-
MISSING 'python3-notify2 needs to be installed'
error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4
OPTIONAL
4.0
-
MISSING 'python3-pyqt4-dbus needs to be installed'
error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x)
REQUIRED
4.0
-
MISSING 'python3-pyqt4 needs to be installed'
python3-dbus
Python DBus - Python bindings for DBus
REQUIRED
0.80.0
1.2.16
OK
-
python3-xml
Python XML libraries
REQUIRED
-
2.2.9
OK
-
error: python3-devel Python devel - Python development files
REQUIRED
2.2
3.8.2
MISSING 'python3-devel needs to be installed'
python3-pil
PIL - Python Imaging Library (required for commandline scanning with hp-scan)
OPTIONAL
-
7.0.0
OK
-
python3-reportlab Reportlab - PDF library for Python
OPTIONAL
2.0
3.5.34
OK
-
--------------
| COMPILEDEP |
--------------
libtool
libtool - Library building support services
REQUIRED
-
OK
-
gcc
gcc - GNU Project C and C++ Compiler
REQUIRED
-
9.3.0
OK
-
make
make - GNU make utility to maintain groups of programs
REQUIRED
4.2.1
OK
-
2.4.6
3.0
---------------------
| Python Extentions |
---------------------
cupsext
OK
-
CUPS-Extension
REQUIRED
-
3.20.6hpmudext
OK
-
IO-Extension
REQUIRED
-
3.20.6
----------------------
| Scan Configuration |
----------------------
scanext
OK
-
Scan-SANE-Extension
REQUIRED
-
3.20.6
--------------------------
| DISCOVERED USB DEVICES |
--------------------------
No devices found.
---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------
HP_DeskJet_3630_series_DA106A_
------------------------------
Type: Unknown
Device URI: implicitclass://HP_DeskJet_3630_series_DA106A_/
PPD: /etc/cups/ppd/HP_DeskJet_3630_series_DA106A_.ppd
warning: Failed to read /etc/cups/ppd/HP_DeskJet_3630_series_DA106A_.ppd ppd file
PPD Description:
Printer status: printer HP_DeskJet_3630_series_DA106A_ is idle. enabled since Sun 06 Sep 2020
04:57:17 PM EDT
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-
Devices.
--------------
| PERMISSION |
--------------
-----------
| SUMMARY |
-----------
Missing Required Dependencies
-----------------------------
error: 'libcups2' package is missing/incompatible
error: 'python3-pyqt4' package is missing/incompatible
error: 'gtk2-engines-pixbuf' package is missing/incompatible
error: 'python3-dev' package is missing/incompatibleMissing Optional Dependencies
-----------------------------
error: 'python3-notify2' package is missing/incompatible
error: 'python3-dbus.mainloop.qt' package is missing/incompatible
Total Errors: 5
Total Warnings: 1
Done.
mike@mike-HP-Pavilion-Notebook:~$
1
1

HPLIP is completely unnecessary for printing with the 3630 on a wireless connection. The command driverless gives you a URI. Substitute for what the command gives you in lpadmin -p 3630 -v URI -E -m everywhere. You should be able to print with the 3630 print queue.

3
  • HPLIP has a bug that makes useless in ubuntu 20.04,i find it strange that this has not been solved by now.but as this answer say you do not need HPLIP to use your printer. – trond hansen Sep 7 '20 at 13:37
  • this is what it says using the terminal driverless ipp://HP%20DeskJet%203630%20series%20%5BDA106A%5D._ipp._tcp.local/ my printer is on my network 192.168.0.10 cups sees it adds it does everything but print still – Mike Burdette Sep 10 '20 at 22:07
  • find and install newer driver from your distribution and hpcus 3.20.11 and see here the photos forum.mxlinux.org/viewtopic.php?f=107&t=63175 – τασος ματσιγκας Feb 15 at 1:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.