0

I need to reformat a 16GB flash drive.

It currently has Ubuntu 20.04 iso on it. I need to erase the contents and put Windows 10 on it.

I found [this answer][1] that looked perfect, but when I tried it I got the message:

This partition cannot be modified because it contains a partition table; please reinitialize layout of the whole device. (udisks-error-quark, 11)

Can someone advise me on my next step?

UPDATE:

Thank you for your kind attention.

Slow response. I hope it comes back this time.

Error: retrieving gpg key timed out.

mkusb is not working out for me.

please reinitialize layout of the whole device.

What is the proper way to do this?

I tried to do it with Disks by selecting the 16GB drive and asking to delete the partition. I got an error message:

Error deleting partition /dev/sdb1: Failed to read partition table on device '/dev/sdb' (Invalid partition table - recursive partition on /dev/sdb.) (udisks-error-quark, 0)

I do not want to install a bunch of stuff to do something so simple. I would like to accomplish it with the Disks that ships with Ubuntu 20.04.

It has to be possible with Ubuntu. What have I missed?

UPDATE:

Just found the USB flasher on my machine. It appears to have written the Windows 10 iso to the flash drive without a problem. I'll find out if it worked when I try to reboot my Windows 10 desktop tomorrow.

UPDATE: I'm typing this on my Windows 10 desktop. The USB Flasher app wrote the .iso to the USB key perfectly. Windows came right up.

I'm happy to have my Ubuntu laptop to rescue me. I'm glad to have found the fix. I'm grateful to those of you who took the time to try and help.

I wish I knew Linux and Ubuntu better. Perhaps with more time I will.

9
  • Are you working in Ubuntu or Windows? If Ubuntu use Disks to unmount the drive, then use GParted to format the drive. I use mkusb-plug to make my Windows installers. Ventoy also works but is not as straight forward. – C.S.Cameron Sep 6 '20 at 13:02
  • I have a Windows 10 desktop that needs a new boot iso after the automatic update failed and turned it into a brick. I've downloaded the Windows 10 iso onto my Ubuntu laptop and need to put it on the flash drive so I can rescue my desktop. – duffymo Sep 6 '20 at 13:04
  • My original problem still stands: I cannot format a flash drive. Next steps seem like they'll be easy. – duffymo Sep 6 '20 at 16:12
  • If you use mkusb-plug, you need not perpare the flash drive, need not format it, because mkusb-plug will overwrite whatever is on the drive. Just go ahead according to the answer by @C.S.Cameron. – sudodus Sep 6 '20 at 19:54
  • Yet I cannot install mkusb, if you read the thread. "Go ahead" - it failed every time I tried. What next? – duffymo Sep 6 '20 at 20:57
2

Installing Windows using mkusb-plug

enter image description here

Step 1

enter image description here

Step 2

enter image description here

Step 3

[enter image description here]4]

Step 4

enter image description here

Step 5

enter image description here

Step 6

enter image description here

Step 7

enter image description here

https://help.ubuntu.com/community/mkusb#Windows_USB_install_drive

3
  • Please see update. Coulldn't get off the dime. – duffymo Sep 6 '20 at 13:46
  • sudo add-apt-repository ppa:mkusb/ppa has always worked for me. See also the most recent info from the developer, sudodus, is here: ubuntuforums.org/… Are you missin an "a" after the last "pp"? – C.S.Cameron Sep 6 '20 at 14:13
  • Yes, I'm a bozo. I missed the 'a' on the copy. gpg key retrieve timed out after correction. – duffymo Sep 6 '20 at 14:19
1

I encountered the same problem when formatting the flash drive.
I first deleted the Ubuntu partitions from the flash drive with Disks and then formatted it.

After formatting i used the Disk Image Mounter application and i copied the files mounted from windows iso to flash drive.

4
  • How do I delete the partitions using Disks? – duffymo Sep 6 '20 at 16:29
  • I see the 16GB drive in Disks when I try to format, but it's not apparent when I try to delete the partition. – duffymo Sep 6 '20 at 18:02
  • There are several partitions on a flash drive. Try deleting each partition separately. – tt177 Sep 6 '20 at 18:49
  • Thank you. I see two. I can't delete either one. – duffymo Sep 6 '20 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.