1

I am on Ubuntu 20.04 and need to use MLA format for citing my resources for a presentation and cannot find a way to do that using Bibtex. I have tried numerous things described in suggestions found while duckduckgoing the topic and it seems that all of them only work on Windows, I don't have any Windows installations to test them on. I have the texlive-full package and am compiling using the following:

$ pdflatex texfilebasename
$ bibtex texfilebasename
$ pdflatex texfilebasename
$ pdflatex texfilebasename

I generally use apalike, but MLA has been specifically requested for my assignment. I found zero results when searching this site for my question. Does anyone know how to get MLA formatting. The usual way that I use apalike is:

\bibliography{bibliography}
\bibliographystyle{apalike}

I have tried "mla" and "mlalike"

EDIT

Here is the code in my .tex file:

\documentclass[12pt]{article}
\usepackage[margin=1in]{geometry}
\usepackage{indentfirst}
\usepackage{setspace}
\usepackage{float, lscape}
\usepackage{hyperref}

\doublespacing{}
\pagenumbering{gobble}

% \author{}
% \title{}
% \date{\today}

\begin{document}

% \maketitle
% \newpage
% \pagenumbering{arabic}

\section*{some good quotes and paragraphs that could be used}
\noindent ``One additional strength of a network-transparency mechanism is that it would benefit not only
individual end users, but also commercial users (e.g., content providers) and network providers
who are interested in whether their peering partners adhere to their contractual
promises.''\cite{transparencyNotNeutrality}

\section*{Transparency With Respect to ISPs}

\bibliography{bibliography}
\bibliographystyle{mla}
\end{document}
1
1

The biblatex-mla is packaged for Ubuntu and contained in texlive-bibtex-extra package.

You have to install it with:

sudo apt-get install texlive-bibtex-extra

Then register mla.bst locally by:

mkdir -p ~/texmf/bibtex/bst/
cd ~/texmf/bibtex/bst/
wget http://tug.ctan.org/tex-archive/biblio/bibtex/contrib/mla/mla.bst
texhash ~/texmf

and then compile your file by xelatex / pdflatex and bibtex as you have planned.

7
  • I have that package installed. bibtex command says: "I can't open style file mla.bst" or mlalike.bst when I use that. Is there a \usepackage tag that need for this to work that isn't needed for apalike? – Astral Axiom Sep 5 '20 at 17:40
  • Thank you, by the way :) – Astral Axiom Sep 5 '20 at 17:47
  • 1
    You can try to get this file manually from tug.ctan.org/tex-archive/biblio/bibtex/contrib/mla/mla.bst . – N0rbert Sep 5 '20 at 17:58
  • I now have the file and have moved it to /usr/share/texlive/texmf-dist/bibtex/bst/base/ and chown it to root:root since, naturally, root owns apalike.bst in that dir. Same error still. – Astral Axiom Sep 5 '20 at 18:10
  • I added the code in my .tex file to my question above – Astral Axiom Sep 5 '20 at 18:22
0

I tried replacing pdflatex with xelatex in the workflow from my question and it still gives the same result. Compiles without error, but bibtex cannot find mla.bst and so I just have [?] Where my citations should be and no references section. Maybe something has been broken between 16.04 and 20.04.

EDIT

Here is the error:

LaTeX Warning: Citation `transparencyNotNeutrality' on page  undefined on input
 line 115.

pdfTeX warning (ext4): destination with the same identifier (name{page.}) has b
een already used, duplicate ignored
<to be read again> 
               \relax 
l.117 \section
          *{Transparency With Respect to ISPs} [2] (./isp_section.bbl
! Undefined control sequence.
<argument> \protect \citeauthoryear 
                                {Pappas, Argyraki, Bechtold, and Perrig}...
l.4   et~al.}{2015}]{transparencyNotNeutrality}
                                           
? X

Here is the bibliography.bib entry, which I got from the ACM Digital Library and only changed the reference name to transparencyNotNeutrality. Syntax highlighting in Vim is not recognizing articleno and numpages, but the issue still remains if those lines are deleted:

@inproceedings{transparencyNotNeutrality,
author = {Pappas, Christos and Argyraki, Katerina and Bechtold, Stefan and Perrig, Adrian},
title = {Transparency Instead of Neutrality},
year = {2015},
isbn = {9781450340472},
publisher = {Association for Computing Machinery},
address = {New York, NY, USA},
url = {https://doi.org/10.1145/2834050.2834082},
doi = {10.1145/2834050.2834082},
booktitle = {Proceedings of the 14th ACM Workshop on Hot Topics in Networks},
articleno = {22},
numpages = {7},
location = {Philadelphia, PA, USA},
series = {HotNets-XIV}
}
4
  • 1
    I was wrong, after filling the bibliography.bib with some data for transparencyNotNeutrality anchor I have the same error about missed mla.bst. So both 16.04 LTS and 20.04 LTS need mla.bst configured correctly. – N0rbert Sep 5 '20 at 18:36
  • So I wonder why bibtex cannot open the file now that it is in the same place as apalike.bst with the same owner, root, and the same permissions. – Astral Axiom Sep 5 '20 at 18:39
  • 1
    I have updated my original answer. Check it. – N0rbert Sep 5 '20 at 18:41
  • I added the bibliography.bib entry and the error I am now getting above. bibtex seems happy now, but compiling fails after running bibtex. – Astral Axiom Sep 5 '20 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.