Since I updated to Ubuntu 20.04, I have been having issues with the lock-screen. The lock-screen works fine the first time that I lock-unlock the computer a short time after a boot. However, if the computer has been running for a while, or it is locked for a second time, the I get stuck in the lock-screen no matter how many times I input the password.

When I try to unlock the computer for the second time, I am presented with the normal lock-screen. I input my password, and click [Enter], then it seems like the computer is unlocking, and I can see my desktop and currently opened apps. However, the computer locks up again after 1 or 2 seconds, and I am presented with a different and more rudimentary looking lock-screen. It does not matter how many times I input my password in this second lock-screen, I get the same behavior: it seems to unlock and I can see the desktop, then it locks again back to the rudimentary looking lock-screen. Moreover, the icons in the top bar of the desktop are changed to the same rudimentary looking ones I see in the rudimentary lock-screen.

First (normal) lock-screen: enter image description here

Second (rudimentary looking) lock-screen: enter image description here

Other problem that I have noticed is that, after the first lock-unlock (which strangely enough seems to work as mentioned earlier), the computer will set the displays to the blank power saving mode in about 30sec, even though it is set to 5min. This only happens if the computer has been lock-unlocked successfully, or the displays went to blank power saving mode before. The only workaround that I found is to prevent the automatic screen lock and disable the black screen power saving mode.

Here is a few more details about my setup (let me know if you need more info):

  • Ubuntu 20.04 updated with the latest updates.
  • Nvidia GTX980 graphics card with the proprietary nvidia driver 440.
  • Tower computer.
  • 2 monitors.


  • Try 'sudo dpkg-reconfigure -a' Sep 4, 2020 at 17:00
  • The terms you should search for are "login loop" and "boot loop".
    – Nmath
    Sep 4, 2020 at 17:09
  • @ArijitChatterjee, I get an error 'Unknown option: a' when I run the command you recommended. Sep 4, 2020 at 17:28
  • @Nmath, I already looked for "login loop" issues similar to mine, and I was not able to find anything that could help me. My issue is not a "boot loop". The computer boots fine, and I have no issues until I lock it. Sep 4, 2020 at 17:30
  • You've done a good job describing the problem, but it would also help to understand the details of your research. You can include the details of everything you've tried so far, and the detailed results of each attempt, as well as any research you have done so far that has enlightened your understanding of the issue you have. If we can know at least as much as you do about the issue, it will put us in a better place to help.
    – Nmath
    Sep 4, 2020 at 17:34

3 Answers 3


I followed @Nmath advice to systematically go over everything I've tried so far to provide better background info, and while I was checking that, I remembered I had installed a bunch of new Gnome extensions when I upgraded to 20.04. I know they are notorious for causing problems, so I decided to check if they were the cause of the problem. Sure enough, disabling them solved the issue. After a bit more testing I found the one that was causing the issue. It's the Time++ Gnome extension. I will be filling a bug report with the developer shortly.

TLDR; disabling the Time++ Gnome extension solved the issue.


I upgraded Ubuntu Studio 18.04 to 20.04 and faced a number of issues including this one. I solved it by disabling 'lock screen' in settings manager/screensaver.


I had the same issue, After uninstalling all chrome remote desktop files and a reboot it is right as rain

  • This is no answer. If you want to comment a "same problem here" is fine, but use the comment feature. If you're not allowed to comment, wait until you have enough reputation
    – kanehekili
    Oct 1, 2020 at 21:07
  • I don't have Chrome Remote Desktop installed. My issue was a poorly coded Gnome Extension. Oct 1, 2020 at 21:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .