20

I am trying to install Ubuntu 12.04 by creating a USB Boot Disk. I am using a 500 GB External Hard-drive ("Elements"). I get through the first part of using the start-up disk creator. I select Ubuntu 12.04 "Precise Pangolin" as the ISO, and my external hard-drive, which has 150 GB free, as the disc to use. I hit "Make Startup Disc". It asks me for authentication before I can copy files, and that part works. Then after copying files, it asks for authentication again to install the boot loader. At this point, it immediately says "Failed to install the bootloader." Any idea why I am having a problem?

3
  • which software did you use for making uSB bootable?
    – KK Patel
    Commented Oct 31, 2012 at 7:20
  • 2
    He mentioned he was using start-up disk creator, "usb-creator-gtk" via the command line
    – sfeole
    Commented Nov 17, 2012 at 1:17
  • 2
    sudo dd if=ubuntu-14.04-desktop-i386.iso of=/dev/sdb bs=1M seems to be working for me. just use lsblk or mount and be sure of the device, you can bork your system.
    – Thufir
    Commented Jun 19, 2014 at 13:55

8 Answers 8

10

I know with Ubuntu Quantal (12.10) usb-creator-gtk is currently plagued with Bug 915626. But your using 12.04

My recommendation would be to start fresh. Open the 'Disks' manager and format your usb drive and delete the current partition. Then recreate a New FAT32 partition and format.

After that is complete try the usb-creator again, see if you make any headway. If it still fails might I suggest a workaround.

In the Software Center look for a program called, "UnetBootin"

Install it and simply select the "Diskimage" bullet. Make sure the 2nd dropdown says "ISO" and press the button to select the ISO you wish to burn onto your disk.

Make sure that your USB Drive is selected under "Type" and the Drive is properly set to /dev/sdb1/ (Assuming your usb disk is /dev/sdb)

Let me know how that turns out!

4

As of July 2015 this bug was not yet fixed in Kubuntu 14.04 LTS.

So, just use the dd command:

sudo dd if=sourceFileName.iso of=/dev/sd*

Where sd* is the name of the USB stick (E.g. sdb).

3

Same message.

You can do it with UNetbootin

Install UNetbootin in Ubuntu

sudo add-apt-repository ppa:gezakovacs/ppa
sudo apt-get update
sudo apt-get install unetbootin

Run UNetbootin

unetbootin
1

Check your partition format . If it was NTFS ,then try to reformat to FAT32 and make your startup live usb again using Startup Disc Creator.

1

I had a very similar problem and solved it by using another usb-maker.

First I was using the KDE default usb-maker on Kubuntu 14.04 and flashed my stick a few times with different live images. Then "something" went not correctly somehow and my pc could not write the bootloader. So I tried

  • another image that worked before
  • compared the sd5 checksum, to see if the image was damaged
  • tried to copy data on the stick an read it from there to check the stick
  • tried to format it and place the partition few GB to the "right" (maybe the chips at the beginning were damaged, I have no idea)...

...same problem everytime at about 54% "couldn't install bootloader".

At the end I was booting from linux-mint 17 and used the default usb-maker from there. Everything worked fine.

So maybe you try unetbootin or also from another distro.

1

I got the same message.

Apparently it has something to do with permissions. Without even taking the USB out I

opened a command prompt and did

sudo -i

then did

usb-creator-kde

It installed without complaint.

1

This error message results from a couple different bugs including one mentioned earlier in this thread.

It happens to me on 14.04 even with a new FAT partition.

Unfortunately the fixes haven't been backported to 12.04 or even 14.04 for that matter.

So, I'd recommend using UnetBootin as mentioned.

0

I have had a similar problem using ubuntu 14.04. Everything seems to work fine until the end where it says "Failed to install bootloader" Although this certainly seems to be an issue, the bootable media still seems to work fine, even after receiving this message. Did you still try booting into the usb stick after receiving the message? In your bios you should have it set to boot into usb if connected, or go to your temporary boot menu (usually esc or f12 while booting) If it still does work it could simply be the specific distro you are installing. Sometimes Xubuntu seems to work better on older computers - especially Dells.

1
  • The original question was from almost 4 years ago. If you had something to add that might help others excellent, however asking the op to act on something this old won't add much.
    – user508889
    Commented May 28, 2016 at 0:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .