1

I am facing the same problem presented here but none of the given solutions seem to work. I am using ubuntu 18.04 and I cannot connect using my ethernet cable -the network manager shows "Unmanaged" under the wired connection. The wireless adapter works fine. I tried the work around of turning "managed" to "true" in /etc/networkmanager/networkmanager.conf but nothing changed even after fully rebooting the computer.

I have changed the content of /etc/netplan/01-network-manager-all.yaml From:

# Let NetworkManager manage all devices on this system
network:
  version: 2
  renderer: NetworkManager

To:

# Let NetworkManager manage all devices on this system
network:
  version: 2
  renderer: NetworkManager
  ethernets:
    enp8s0:
     dhcp4: yes
Adding "ethernets: enp8s0: dhcp4: yes"

The output of sudo lshw -C network is:

  *-network                 

       description: Wireless interface
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: wlp7s0
       version: 73
       serial: a0:a8:cd:13:30:cb
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.15.0-96-generic firmware=17.948900127.0 ip=192.168.1.6 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:31 memory:d1500000-d1501fff
  *-network DISABLED
       description: Ethernet interface
       product: QCA8171 Gigabit Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: enp8s0
       version: 10
       serial: 60:02:92:25:97:36
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=alx latency=0 link=no multicast=yes port=twisted pair
       resources: irq:18 memory:d1400000-d143ffff ioport:3000(size=128)

The output of lspci -nnk shows that the kernel driver in use is "alx".

Trying "sudo ifconfig enp8s0 up" does result in enp8s0 appearing in the output of my ifconfig but the "unmanaged" is still there and I cannot connect to the internet using the wired connection.. I have also tried "sudo ip link set enp8s0 up". It just removes the "disabled" from the lshw -C network... but still nothing seems to work.

Any suggestions would be really welcome. Thank you!

0
1

After some more digging I found out the answer here: https://superuser.com/questions/1429490/unmanaged-network-manager-in-ubuntu

Creating this empty file fixes the problem: /etc/NetworkManager/conf.d/10-globally-managed-devices.conf

I have no clue why though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.