I recently upgraded to Ubuntu 12.04 and after doing some updates and such my application launcher and title bars (for window dialogues) are missing. Basically the entire Unity GUI is missing!

Not sure what happened so I installed GNOME 3 and it was missing a launcher too, but did have title bars. In addition the bar found at the top that lets you know what's open and allows GNOME extensions to be displayed is not interactive. I can't click, right click, alt + click (right or left), alt + super click (right or left) anywhere! I even installed an application menu from the GNOME site and it is not interactive either. However, since there is no way to launch applications I have to use terminal and if I minimize an app it will disappear completely.

Then I decided to try Unity 2D and it is incredibly messed up. Black background, launcher is there but icons and top bar while on desktop are completely distorted. They're not just pixelated; they're all sorts of funky colors and when I open something from Unity 2D launcher it will show it's opened in the launcher but nothing appears on my screen.

When trying to view videos on YouTube the video is distorted and looks just as Unity 2D does. Strange enough: the audio works fine, just not videos. Pictures loads, but not ads that stream video.

Any suggestions to get my launcher and the Unity GUI back? I tried reinstalling GNOME, Unity 3D, and Unity 2D from terminal. No change. Also reinstalled Unity desktop and tried resetting it: nothing happened.


10 Answers 10


I had the same problem. I tried with unity --reset (as it used to fix things when I messed things up before with compiz-config) but that didn't solve my problem now. The only thing I could do for getting everything working as normal was to reset compiz settings.

Just backup (rename) ~/.compiz-1 and ~/.config/compiz-1 directories and let them to be created again with the default settings (you'll need to logout and log back in again).

mv ~/.compiz-1 ~/.compiz-1.BACKUP
mv ~/.config/compiz-1 ~/.config/compiz-1.BACKUP

After having restarted and confirmed that everything works as expected, you can simply remove these backups (unless you have a use for them).

rm -Rfv ~/.compiz-1.BACKUP
rm -Rfv ~/.config/compiz-1.BACKUP

Note: To some people, one of the following links might have the solution. Try them if you don't want to lose all your compiz customizations.

In my case just resetting Unity wasn't enough, so I decided to get rid of all compiz settings.

  • where do i find the directory to rename it? dconf-editor? what did you rename the two directories? Apr 28, 2012 at 21:59
  • On you home directory (that's the ~)
    – Simón
    Apr 29, 2012 at 5:24
  • I did this and compiz CPU dropped below 10% at idle. Previsouly it was arround 40%. Thanks a lot
    – ECII
    Jun 17, 2012 at 17:11
  • I am having the same problem, I can't even start a terminal to handle this.
    – FarhadA
    Oct 26, 2012 at 9:04
  • 1
    1. Using Ubuntu 14.04 unity --reset is depcrated and won't work. 2. My compiz-folders don't have a added "-1" at the end. Removing those it worked like a charm.
    – MadMike
    Jan 24, 2015 at 12:57

I had the same problem. I tried this.

  1. Press Ctrl+Alt+F1 to switch to the CLI/tty.

  2. Check if unity package installed:

    dpkg -l | grep unity

    If 'unity' is listed in the output, proceed with the next step. If not, install it (and its dependencies):

    sudo apt-get update
    sudo apt-get install unity
  3. Check if 'ubuntu-desktop' installed:

    dpkg -l | grep ubuntu-desktop

    if not, install it:

    sudo apt-get update
    sudo apt-get install ubuntu-desktop
  4. Restart your display manager.

    If you're a Natty user, you need to restart GDM:

    sudo service gdm restart

    or if you're on Oneiric and later you need to restart LightDM instead (default):

    sudo service lightdm restart

Simon's method works if you are not able to open terminal you can work in login shells(virtual consoles). @erik you could have done it in any virtual consoles


I think it would have worked.


In my case I had an old .gnomerc file that seemed to be the culprit. Probably from some very old compiz install (circa 2008). Removing the file solved the problem for me, may help someone else.

File was:

cat .gnomerc

rm ~/.gnomerc and reboot or log out/in.


If you have a blank screen and nothing else apart from the mouse, you should still be able to call up terminal.

If so, install CCSM if you haven't already done so:

sudo apt-get install compizconfig-settings-manager 

Then once it's installed, in the same terminal just do:


When the manager GUI pops up, go to desktop/ubuntu unity plugin and make sure it's enabled.

If it's already enabled, disable and then re-enable, log out and log back in and all should be back to normal.

If you have the issue where Compiz continues to crash at boot, simply create a shell script:

sleep 3
compiz --replace

You can then simply add this to your start up applications and it will reset Compiz on boot, obviously making sure you have made the file executable first though.


Removing the Compiz directories worked for me, but since I could not get a terminal, I had to do the following:

  1. Boot Ubuntu Live from a CD
  2. Open a terminal window and issue 'sudo -s' to get root privileges (no password required)
  3. do a df command to see the drives on the system (it will be a long name....)
  4. cd /media/[drive name]
  5. cd [your normal home directory]

Now you can rename the compiz directories as per above. Shut down the live session, remove the CD and boot from the hard disk.

It worked for me. YMMV.

  1. if you have no live cd by hand just press CTRL+ALT+T
  2. for hack more:
    • create launch.sh with right mouse button on the desktop with text "gnome-terminal" in it (without quotes).
    • Set executable bit for this script in properties with RMB.
    • Execute it.

Thank you! After upgrading to Precise, Unity was disabled (although not at first).

Installing compizconfig-settings-manager Install compizconfig-settings-manager, running it via ccsm and applying the necessary changes to start Unity again did the trick!

  • 4
    What would the necessary changes be, here? Aug 3, 2012 at 18:06

I have the same issue after doing an upgrade on my machine i lose the desktop backgroun and it remain totally black, but when i open my terminal it shows that there is a background. I tried other steps mention here on this thread. It turn out that the cinamon is the culprit.

What i did is

$ sudo apt-get remove cinamon*

Then rebooted

Login to Gnome Classic - No effects

It Worked!


I had pretty much the same problem under 12.04. Unity was slow with my aged GPU, so I was using Unity 2d as my desktop for months. For no apparent reason, it suddenly refused to display launchpad and title bar (for all users). Reenabling Unity in CCSM as suggested above was part of the solution, but none of the other measures suggested here, or in several other related threads, including, but not limited to:

  • Reinstalling unity

  • Reinstalling ubuntu desktop

  • Removing all relevant (e.g. compiz, gconf, etc.) configuration information

helped me to completely resolve these symptoms under 12.04 (64 bit).

unity --reset

would not work for me. After delivering a variety of error and information messages, it would always hang at:

Setting Update "run_key"

as shown in the log posted in the thread titled "unity has vanished" for unity run with no arguments.

I noticed that the error message delivered by:

/usr/lib/nux/unity_support_test -p

was similar to some of the errors reported by unity --reset:

error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory.

as reported by user139869 here. Unfortunately, his solution did not work for me. After extensive searching, I found the following solution:

  1. Get the path of libGL.so.1 by using the command locate libGL.so.1.

  2. Add a link to the library in /usr/lib/ as shown in the following example:

  3. sudo ln -s /usr/lib/i386/mesa/libGL.so.1 /usr/lib

    (courtesy of J.D. Bartlett)

  4. Restart the computer.

This not only allowed both unity_support_test-p and unity --reset to run, it also allowed Unity 2d to start. I have no idea what caused my problems, but since creating the links above (several weeks now) I have had no further problems.


All you have to do is; Start Ubuntu tweak, go to Tweaks menu, select Desktop Icons, and change Show Desktop Icons to On.

and that's it!

  • The problem is not missing desktop icons but Unity Launcher.
    – Peachy
    Oct 2, 2012 at 8:22

Not the answer you're looking for? Browse other questions tagged .