0

My computer has two operating systems, Windows 10 and Ubuntu 18.04. Today, when I tried to get into Ubuntu (I already laid it aside for about one week), the whole screen showed pure purple for at least 10 minutes, so I forced the computer to shutdown. Then when I tried to get into Ubuntu again, it showed:

Then I tried to open Ubuntu in recovery mode,but the outcome was same. And I also tried this solution:missing modules (cat /proc/modules; ls /dev) - Linux Mint Forums which doesn't work either. At last I run fsck.ext4 -y /dev/sda1(where the root is),and showed:

Anyone know how to deal with this issue?

  • 2
    Did you recently install a Windows Update? – user535733 Sep 2 at 16:54
  • @user535733 Good observation. The FS is vfat. – heynnema Sep 2 at 17:30
  • @user535733 I think so. – OilLight Sep 4 at 1:59
  • Your output indicates the the filesystem is VFAT intead of EXT, which means you have some strange non-standard install of Ubuntu. We need to know about that. – user535733 Sep 4 at 2:01
  • I partition my disk manually when installing Ubuntu: '/' primary partition Ext4 30720MB, '/boot' primary partition Ext4 1024MB,'/home' logical partition Ext4 51200MB,'/tmp' logical partition Ext4 10240MB,'/usr' logical partition Ext4 102400MB,'/var' logical partition Ext4 10240MB,swap logical partition 10240MB – OilLight Sep 4 at 10:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.