56

There was an option to change background to solid color. However, I notice that that option is no longer there.

The only options available are to use existing image or to add picture.

Was this setting moved to somewhere else?

enter image description here

Here are some of the option available in the previous version

Ubuntu Studio 18.04 64-bit

Why can't I change my background to a solid colour

Look at the solid colour settings there

enter image description here

2

7 Answers 7

80

Newer versions of Ubuntu Desktop have removed the capability to set the background to a solid color. You may run the following command in a terminal window to accomplish this task:

To clear the current image setting:

gsettings set org.gnome.desktop.background picture-uri none

To set the primary color (the first color in a gradient or the solid color):

gsettings set org.gnome.desktop.background primary-color '#000000'

Reference: https://www.fcpace.com/node/55

6
  • 10
    Another reason to love linux.
    – Just_Alex
    Sep 14, 2020 at 5:36
  • 3
    A slightly more elegant way to remove the picture might be to set picture-options to none. (Although I suspect Gnome is much smarter than to try and load a picture from an empty string.)
    – mwfearnley
    Mar 7, 2021 at 11:53
  • This will probably pollute the logs with an error where it does not find an expected bitmap background image.
    – Levente
    Mar 27, 2021 at 17:29
  • 1
    Works on 21.04! Jul 23, 2021 at 15:37
  • On 22.04 setting picture-options instead of picture-uri is required.
    – graywolf
    Apr 5 at 15:53
19

So building on Sabrina's answer to create a plain colour gradient background without messing around making an image the following works:

gsettings set org.gnome.desktop.background picture-options 'none'
gsettings set org.gnome.desktop.background primary-color '#004000'
gsettings set org.gnome.desktop.background secondary-color '#306030'
gsettings set org.gnome.desktop.background color-shading-type 'vertical'

The primary colour will be the top (or left if you go for horizontal instead of vertical) and the secondary colour will be the bottom (or right).

4
  • Honestly, best answer here. It is BS that they've changed (removed) so many items on Ubuntu 20.004. I was lastly using 16.04.10 and have just switched as of today, and want to have ZERO images on this machine (in order to run a special program I need to run) and I come looking on how to NOT have an image as a background, and the FIRST and highest rated answer tells you "how to draw a different image" (that looks like a gradient), if you don't like the ones they have provided by default.
    – PyTis
    Jan 13, 2022 at 6:42
  • 1
    Like seriously, WTF. I honestly do not even understand how it even got a single up-vote, let alone the 52 it currently has. Back to the issue at hand, IF ANYONE can link me to a page where they are discussing the removing of colors, and forcing of images for backgrounds, I would greatly appreciate it.
    – PyTis
    Jan 13, 2022 at 6:42
  • @PyTis so just use the "picture-options none" line in the above. and maybe also set a primary-color if you don't want plain black.
    – RogerCO
    Jan 17, 2022 at 9:07
  • This method also works in 22.04 - well done
    – Piotr L
    Apr 22, 2022 at 12:20
16

For people using the dark theme on recent releases of Ubuntu, there is another gsettings value that may need to be set.

  1. First, clear the background image:
    gsettings set org.gnome.desktop.background picture-uri-dark none
    
  2. Set the background color:
    gsettings set org.gnome.desktop.background primary-color '#000000'
    

Just as with Sabrina's answer, this will show a nice black background again.

(Must be a new feature, as I already did the changes before and it worked. After an update, I got a background image again...)

1
  • 3
    works for 22.04 LTS
    – Adam
    Apr 28, 2022 at 16:59
3

You can also find these settings using dconf Editor

  1. Install dconf Editor apt-get install dconf-editor
  2. Paste the path /org/gnome/desktop/background into the URL edit box
  3. Click on picture-uri and set the path to blank
  4. Modify your color

dconf Editor desktop background settings

0

I used my iPhone with the flash turned off to take a picture of "solidblack" (no shortage of black plastic in my house), then imported and applied the photo to my 20.04 desktop. This worked fine. I also did some testing with an upgrade from 18.04 to 20.04 where the desktop was already set to solid black. The upgrade preserved that setting.

1
  • 3
    Good resourcefulness. But instead of taking and importing a photo, you could create one cleanly from the terminal, e.g: sudo apt install imagemagick; convert -size 1920x1080 canvas:black black.png (see also stackoverflow.com/questions/39504522/…)
    – mwfearnley
    Feb 2, 2021 at 15:37
0

Solid and Gradient Wallpaper

I use Open Office Draw to create my gradient backgrounds, then export the .odg file as a .jpg. I select this .jpg when I Change Background. I increase the size of the image a little when exporting it. You are welcome to my image, (attached), if you like. In my opinion 20.04 has the worst screen images of any Ubuntu to date.

enter image description here

enter image description here

2
  • For a simple gradient, you may well find that PNG is both better quality and smaller than the equivalent JPEG.
    – mwfearnley
    Feb 2, 2021 at 15:30
  • 3
    Like seriously, WTF. I honestly do not even understand how it even got a single up-vote. I come looking on how to NOT have an image as a background, and the FIRST answer tells you "how to draw agradient-like different image," if you don't like the ones they have provided by default. The question ASKED was how to NOT use an image, and how to use a color, and you answer with, here is a way to use an image? Back to the issue at hand, IF ANYONE can link me to a page where they are discussing the removing of colors, and forcing of images for backgrounds, I would greatly appreciate it.
    – PyTis
    Jan 13, 2022 at 6:44
-1

Sorry it took too long to answer this.

Find Desktop | Background | Style and select None.

You're welcome.

1
  • 1
    This option doesn't exist on Ubuntu 20.04 with the GNOME desktop environment. Do you perhaps use another desktop environment or another version of Ubuntu? Jun 26, 2021 at 20:02

You must log in to answer this question.