1

I was trying to configure Samba in two computers (both with newly installed Kubuntu 20.04 and Lubuntu 20.04), and I did it like how I used to do in the past with other *Ubuntu installations: I install Samba, add a share (with Lubuntu I need to do it manually, but whatever) and with Kubuntu I installed to Smb4K which is a great tool to find and mount Samba shares.

The issue I have is they can't find any Windows shares. I have some computers with Windows 7 and Windows 10, and we use them in the network; they have shares configured that work between them and also I can search and use them with tools in an Android mobile. They work normally, like they should, but when I search them in those *Ubuntu machines, they don't find those Windows servers. I tried to search them with Smb4k, Dolphin (Kubuntu) and PCMan (Lubuntu), and also with smbtree with both, what shows nothing.

However, I can mount them. If I enter smb://WINSERVER (WINSERVER being any Windows Server in the network) in the Linux File Managers, they show me the shares and I can enter in them. With Smb4k, I can mount using //WINSERVER/WINSHARE. With smbclient -L WINSERVER shows the shares from that server.

But, both *Ubuntus find each other with Dolphin and PCMan (respectively). And from the Windows computers, the *Ubuntu servers appear and I can reach the shares and files.

The installation of Samba in both computers are pretty vanilla. I only change the workgroup in smb.conf to match all the computers. There is no password anywhere.
I searched and tried a bunch of things, but none fits with my issue. I found issues like "can't mount shares" (in my case, I can) or "Ubuntu shares don't show in Windows" (in my case, it's the opposite). I tried to install WINS service (winbind), but i have the same behaviour.

Anyone has a clue of what's happening or what I can research to find the issue? (I can provide any log or cfg needed)

1 Answer 1

0

You had better get used to this, until the Linux tools catch up with Samba. Your problem is that Samba >= 4.11.0 now has SMBv1 turned off by default (shortly to be turned off permanently) and SMBv1 is required for network browsing. Your Linux clients will be finding each other via Avahi and your Windows clients will be using Network Discovery. Winbind has nothing to do with WINS, it is nmbd for that and again it requires SMBv1.

1
  • I am going to accept this as solution because is what put me on the right path. Something funny is with a android app (CX Explorer), i can find all shares (for sure it uses other discovery method). Other question would be how (and when) do a right setup for all these to make it working properly like i want, but, like i said, that's other question. Thanks! Sep 3, 2020 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.