I am trying to upgrade from 11.10 to 12.04. The machine is acer aspire core i3, 2.1ghz, ram 6gb, hard disk 500 gigabyte. I am using a usb stick with a downloaded 12.04 live install. The install progressed with an overwrite of 11.10 system files to 12.04 and then got stuck. The install is stuck at 'restoring previously installed packages' How can i recover from this situation ? please help.



Firstly, if you are upgrading, you should have used the update manager instead of a livecd to upgrade. If your system is being overwritten, then your home folder may get overwritten unless it is in a separate drive.

How long has it been since it got stuck? Sometimes, during upgrade, things can appear to get stuck but in the background the upgrade may be running.

Check using top command in an open terminal which process is using the most cpu/ram. Generally the process which gets stuck eats the most CPU.

  • 1
    Why shouldn't a person upgrade from a live dvd/usb? Firstly, it's a valid option after you boot a live usb and it should be supported. Secondly, if you have Ubuntu installed on several machines it makes much more sense than downloading the new packages from the internet X times. – metakermit Oct 20 '12 at 13:38
  • no it does not because the live cd does not contain updates for restricted drivers and other installed packages from multiverse repositories – Ubuntuser Oct 20 '12 at 17:16
  • 1
    Well, then it shouldn't be offered as an option when starting a live usb installation. But I still don't think removing this option would be a good way to go, as I don't see the point in downloading the same data several times. It's a waste of resources. – metakermit Oct 21 '12 at 9:29
  • its downloading the data only once. if you have an unlimited high speed internet connection I do not see any harm in wasting a little resources. it would download in 10-15 mins, about the same time it would require to read from a CD/DVD – Ubuntuser Oct 22 '12 at 22:39

I just ran into this problem on my desktop and solved it by switching network adapters. So perhaps try the ethernet port if you are using the wireless or vis-versa if using the eithernet port already.

It may also help to simply disable and enable the networking. Hope this helps!

  • Same here. Fiddling with the network connection, putting my notebook in suspend and waking it up again... Somehow it worked for me! – marcvangend Oct 18 '12 at 22:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.