0

I'm new to Linux, and I've started to play around with a server, as I would like to learn more. I originally setup the server on 19.04, and had a Plex server, and a network shared drive. I had to reinstall linux (20.04 LTS now), because 19.04 dropped support, and it started to cause many issues. I tried to migrate my Plex server, but I used snap to install it, it was recommended to install it from the command line, so if I ever had to migrate it again, I would be able to take the data from it. That caused an issue where it couldn't read my 4TB NTFS drive, with all the movies on it. I mounted it in /disks/4TBHDD, but now I can't seem to share it with my windows PCs. Samba gives the "net usershare error 255" where I apparently don't own the drive on my account. I've tried to use chmod to get my permissions back, but it doesn't seem to work. I'm completely lost on what to do now, I'd really prefer to not have to reinstall again, as it's a pain, and I've already gone through about 4 different OSs on the machine (windows, inefficient moved to 18.04 server, needed GUI, so moved to 19.04, but realized that I need LTS, so moved to 20.04)

I'd really appreciate any help here, I'm completely new to Linux, and not very great with using a terminal yet, so I'd really appreciate any help here.

0

Samba gives the "net usershare error 255" where I apparently don't own the drive on my account.

There are 2 ways to handle this particular error:

[1] Replace the owner of the mounted NTFS partition from root to you.

You would do that by adding to the list of options in /etc/fstab for this partition a uid=1000 if that is your uid number. To find out run id

[2] OR, Make it so you can create a samba share from Nautilus for directories you do not own.

Edit /etc/samba/smb.conf and under the workgroup = WORKGROUP line add this one:

usershare owner only = No

Then restart smbd: sudo service smbd restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.