1

I tried to install Libreoffice on Ubuntu 12.04 (after an upgrade), and now I can't install, ugrade, anything in any form. When I go to the Software center, I get a message that I need to repair the package catalog before I can install anything. But the repair fails because of Libreoffice files.

When I try to run sudo apt-get -f install, or sudo apt-get upgrade, or anything else, those libreoffice files prevent any solution.

I tried:

sudo dpkg --configure -a
sudo apt-get install -f
sudo apt-get update
sudo apt-get upgrade

But that didn't help either.

Here is the output of both the install and repair attempts: http://pastebin.com/A8ztjDTR

Unpacking libreoffice-common (from .../libreoffice-common_1%3a3.5.2-2ubuntu1_all.deb) ... dpkg: error processing /var/cache/apt/archives/libreoffice-common_1%3a3.5.2-2ubuntu1_all.deb (--unpack): trying to overwrite '/usr/bin/soffice', which is also in package openoffice.org-debian-menus 3.3-9556 No apport report written because MaxReports is reached already

Any suggestions?

2

The openoffice.org-debian-menus is the cause of your problems. This should sort it:

sudo dpkg -i --force-overwrite /var/cache/apt/archives/libreoffice-common_1%3a3.5.2-2ubuntu1_all.deb

Then you should be able to continue with your upgrade.

  • I used aptitude to remove all traces of Libreoffice, and now I can start over. I suppose that your solution would have worked better. Thanks. – Bryan Meadan Apr 29 '12 at 5:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.