0

I just upgraded my motherboard/cpu and can't access my BIOS when the computer starts up. I have no options to press DEL (as indicated by the manufacturer), or F11 to access the boot options (which I believe is the correct key, based on my experience with MSI products). Luckily, the computer boots properly to my operating system and runs like a charm otherwise.

I DID have some issues with some drivers not being installed (Realtek r8125 Ethernet driver) that I had to install on my own. Could there be something else that I need to install as well?

I am running Ubuntu 20.04 LTS, if that's helpful. Thanks!

5
  • have you tried all possible keys? F1, F2, F3, F10, F12, ESC, Tab sometimes even crazy stuff like Ctrl+Alt+F3, Ctrl+Alt+Ins, Fn+F1 for lenovo. Aug 29, 2020 at 15:38
  • All motherboards are different. You really have to read the documentation. I'm sure it's on their support website. Let us know if you still have a problem after consulting the docs. You'll be better informed to ask if there is still a problem.
    – Nmath
    Aug 29, 2020 at 15:46
  • pg 46 of the documentation found here (download.msi.com/archive/mnu_exe/mb/E7C75v1.0.pdf) indicates DEL to access BIOS, and F11 to access boot menu. There is still a problem.
    – Mark Nitz
    Aug 29, 2020 at 15:55
  • Then either your keyboard is dead or your motherboard. Nothing in Ubuntu has even started to load at this point in your boot. Try another keyboard and if that doesn't work then RMA. Ubuntu will not be able to fix broken hardware
    – Nmath
    Aug 29, 2020 at 17:54
  • It's an MSI. It's the ESC key. If you enabled the quick boot, power off and then press the power button and hold it for four seconds.
    – KGIII
    Aug 29, 2020 at 21:47

2 Answers 2

1

If your board has a slot for a ps/2-type keyboard, use that, as you probably set the legacy USB options off and you have a USB keyboard, that now does not work until after the boot screen is gone. (yes, it boots a second faster, but you lose the keyboard.) I suggest resetting the BIOS with the jumper and start over.

(certified MSI tech)

1
  • That sounds like something MSI should really fix. PS/2 keyboards are about as common as mice that have a rubber trackball underneath.
    – Nmath
    Aug 29, 2020 at 17:56
0

Try pressing the power button for 4 seconds, right after boot. On my MSI motherboard, that will trigger it to go into the bios.

Another trick I used, is to remove all bootable media. Just take the NVM drive out of the slot, and unplug your SSD / HD, remove any bootable USB / DVDs.

I had the same problem as you, and the second solution worked for me, and once inside i saw there was a setting describing the first solution (press power 4sec)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.