1

I have two access points available at home. They share the same SSID and the same security settings: WPA2, AES, same pre shared key. I have Two Android devices and one Acer laptop with Windows 10 installed. all of these roam perfectly when getting far away from one AP and near the other one.

In addition, I have 2 Lenovo ThinkPad X1 Carbon 6th generation laptops with Intel 8265 adapter running Ubuntu 18.04. These do not roam unfortunately and stick to the currently connected AP. I use iwconfig and see that the far away currently connected AP signal level is -82 dBm and using iwlist scan I see the nearby AP has a signal level of -38 dBm. Still, roaming does not happen. If I turn the Wi-Fi off and on, the close AP is being used as expected.

Here are the available firmware versions:

$ ls -al /lib/firmware/*8265*
-rw-r--r-- 1 root root 2389968 Nov 17  2017 /lib/firmware/iwlwifi-8265-21.ucode
-rw-r--r-- 1 root root 1811984 Apr 24  2018 /lib/firmware/iwlwifi-8265-22.ucode
-rw-r--r-- 1 root root 2234528 Dec  5  2017 /lib/firmware/iwlwifi-8265-27.ucode
-rw-r--r-- 1 root root 2307104 Dec  6  2017 /lib/firmware/iwlwifi-8265-31.ucode
-rw-r--r-- 1 root root 2440780 Apr 25  2018 /lib/firmware/iwlwifi-8265-34.ucode
-rw-r--r-- 1 root root 2498044 Jun 17 15:56 /lib/firmware/iwlwifi-8265-36.ucode

I tried the following but they seem to have no effect:

  • Based on this explanation I tried disabling Wi-Fi power saving by setting wifi.powersave = 2 in /etc/NetworkManager/conf.d/.
  • Based on this answer regarding roaming aggressiveness I set the following parameters in /etc/modprobe.d/aggressive-wifi-roaming.conf:
options mac80211 probe_wait_ms=100  # instead of 500 by default
options mac80211 max_probe_tries=1  # instead of 5 by default
options mac80211 beacon_loss_count=1  # instead of 7 by default

When testing on the same laptop using Ubuntu 20.04.1 live, the roaming issue is gone.

How should I further debug / fix this on Ubuntu 18.04?

5
  • Do both access points have EXACTLY the same SSID and WPA2 security settings?
    – heynnema
    Aug 29, 2020 at 0:10
  • Yes. As mentioned, I have three other devices roaming as expected.
    – Alon
    Aug 29, 2020 at 8:53
  • Does that "yes" mean the SSID/WPA2 are the same? Edit your question and show me ls -al /lib/firmware/*8265*. Boot to a Ubuntu Live 20.04.1 DVD/USB and see if roaming works.
    – heynnema
    Aug 29, 2020 at 12:51
  • Same SSID/WPA2. Edited the question to include this information.
    – Alon
    Aug 29, 2020 at 23:09
  • Roaming works great on Ubuntu 20.04.1 on the same laptop. Any idea why?
    – Alon
    Aug 29, 2020 at 23:10

1 Answer 1

0

From the comments...

Booting to a Ubuntu Live 20.04.1 DVD/USB and roaming works.

Upgrade from 18.04 to 20.04.1 on your Lenovo ThinkPad X1 Carbon 6th generation laptops.

2
  • Do you know what specifically in 20.04.1 makes it work?
    – Alon
    Aug 29, 2020 at 23:51
  • @Alon Technically, no I don't. I'd guess just general improvements in NetworkManager and the comm drivers.
    – heynnema
    Aug 29, 2020 at 23:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.