0

So recently I got given a iMac Early 2006 basically speced out as much as possible from factory (Intel Core Duo, 2GB of RAM, DGPU). I wanted to try to run some modern programs on it, as the newest version of Mac OS X is Snow Leopard, and even Windows 7 doesn't run great on the iMac (but Windows XP does!) So, as the computer is 32-bits, I downloaded lubuntu 18.04 and burned it to a DVD. It booted into the live DVD just fine, and was installing, until it said that either the DVD drive or the hard drive was dirty or bad. Anyway, right before that Windows XP ran just fine on it, so I tried burning 18.04 instead of 18.04.4, and that worked! Went and restarted, and tried booting into lubuntu. Well, after a couple of seconds, just rebooted. I went into the grub menu and added nomodeset, and I found it restarted right as it hit something about networking (which I did not connect to during setup). I also found if in Restore Mode I try to use anything that requires internet, it will restart. So, what could be going wrong here? Is there a way to just stop internet from becoming active during boot so I can actually get it to start?

ANSWER FOUND BELOW

3
  • Suggest you edit your question to tone down the narrative and focus on the actual question. "My system is this, my problem is this" Aug 28 '20 at 16:21
  • 2
    Does this answer your question? "errno 5 - input/output error" when trying to install Ubuntu
    – guiverc
    Aug 31 '20 at 8:13
  • Well, at first that did happen,. But, then I burned a DVD with just 18.04 instead of like 18.04.4, then it installed fine, but now this is happening. Sep 1 '20 at 21:25
0

So I tried Unetbootin, and that installed Lubuntu just fine, (although it was 16.04). So, I tried installing 16.04 with a DVD, and same thing happened with above. I was confused until I realized, that Unetbootin uses MBR because it's using Windows, and a normal Lubuntu install uses EFI. So, I'm gonna try installing 18.04 again but format the disk as MBR and I'll let you know if it works!

UPDATE: First boot after installing Lubuntu 18.04 on MBR instead of EFi, and yep, it works! I've had a lot of issues with linux EFI on Mac, including my newer Mac Mini, so seems like MBR is the way to go. Now, with Unetbootin, after trying to update, it would restart during boot-up like before, so I'm gonna try to update it, and see if it will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.