Here's what the problem is.

About a day or so ago I used Gparted live cd to create 3 NTFS primary partitions on my external 500 gig Goflex and one extended with 2 logical partitiones.

I had planned to install windows 8 on the first partition, then ubuntu and kubuntu on the other 2.

After I finished partitioning my drive with gparted, I booted into windows vista to make my bootable windows 8 usb to install it with, I also decided to check to make sure all my partitions were working properly.

Then I found they were, and they weren't.

My 50 gig first partition I had planned to install windows on showed up normal and the 300 gigs of space left in the extended partition did as well, the rest showed up as raw.

So I figured alright, something went awal while making the partitions, so I booted up gparted once again.

Then to my surprise gparted showed the entire drive as unallocated, and when I refreshed the list, it showed as all the partitions I had made earlier, buy with a exclamation mark by them all.

So I figured ok, might be a problem with the partition table as I'd seen a similar problem in past on a drive that was not partitioned at all, so I decided to create a new partition table and take the time out again to sit and wait.

Then I got a message saying gparted could not create the partition table, followed by it showing the entire drive as formatted into ntfs.

After that I figured ok I'll take a break, come back in a hour, maybe it's something I did.

So a hour later I came back after having booted up windows, plugged the drive in to see if by some miracle windows could access the drive.

In disk management when I plugged the drive in, it would freeze attempting to read the drive, as I'd seen in the past with raw disks, yet when I unplugged it I got a glimpse of disk management showing it as a perfectly fine ntfs file system on the drive followed by a "you must format disk K in order to use it".

So I then was assured the disk was raw as that is what had happened in the past, followed by a new partition table through gparted to fix the problem and a 10 hour format in windows.

So I once again booted up gparted, to get the message "error fsyncing/closing/dev/sdg:input/output error" followed by "error opening dev/sdg No such file in directory" after I refreshed and somehow saw the disk show up as perfectly fine ntfs and then tried to create a new partition table to try to wipe out all my problems and start over again.

And not gparted only shows the drive there about 1/10 refreshes the rest I get the directory error.

If anybody can assist me in any way shape or form I will be thankful.

  • 2
    I am not sure but I think Windows can't recognize extended volumes properly. U should install Windows on primary partitions.
    – thonixx
    Commented Apr 29, 2012 at 21:14
  • Although you intend to eventually install Ubuntu, it seems to me this question isn't really about Ubuntu in any way. You're using a GNU/Linux distro--the GParted Live CD (which is not Ubuntu). And you're getting stuck on creating partitions that you can then see, especially in Windows. This question is probably off-topic for Ask Ubuntu. If you still need help, this would probably be more appropriate for Super User. Commented Apr 10, 2013 at 10:29
  • Maybe a HDD error? Try run a smart scan on the disk.
    – user371765
    Commented Feb 27, 2015 at 1:06
  • Ubuntu should never be installed on NTFS. Change the kubuntu and ubuntu partition's filesystem to ext4!
    – Star OS
    Commented Dec 21, 2015 at 9:04
  • What you're seeing isn't normal. Maybe check the livecd? (md5/sha256 or other checksums, linux livecds normally have an integrated function to do that) Commented Jun 13, 2017 at 5:35

5 Answers 5


Why do you create so many NTFS partitions in the first place? As for your info, Ubuntu/Kubuntu can't be installed on one of those, they require a Linux file system like ext4.

I'd suggest the following:

  1. Delete all partition.

  2. Use Vista to create a primary NTFS partition for Windows8, and then proceed installing it.

  3. Install Ubuntu and Kubuntu. You can create partitions for them inside the installer.

  • 1
    That's the thing, I have been attempting to delete the partitions and create a new partition table but I can't gparted can't even do it.
    – William
    Commented Apr 28, 2012 at 16:24
  • Any particular reason to insist using Gparted? It doesn't seem to work very well for you. Commented Apr 28, 2012 at 16:30
  • It was working fine till now, any it's the only partitioning software that has worked well for me before. If you know of a better partitioning software, I'll try it out.
    – William
    Commented Apr 28, 2012 at 16:35
  • Try using fdisk. It's command line but it's not that bad. It has a very detailed menu. Commented Aug 15, 2013 at 18:27

My suggestion is to try:

Plug your external hdd.

Open a terminal,

Press Ctrl+Alt+T

Run it:

sudo -i
fdisk -l

Suppose your disk is /dev/sdg, continue running:

dd if=/dev/zero of=/dev/sdg bs=1M

By gparted create a GPT partition table.

If your PC is (U)EFI aware via the BIOS, create a first partition EFI bootloader (ef00 EFI System) 500 Mg

If your PC is not (U)EFI aware via the BIOS, create a first partition BIOS boot partition, (ef02 BIOS boot) 500 Mg

A continuation of this partition, leave 80 Gb free, to install Windows 8.

Then create partitions for swap (8200 linux swap) and shared /home (8300 Linux filesystem) ext4, (using same username and password) to Ubuntu and Kubuntu.

And then finally create partitions for each /,(8300 Linux filesystem) ext4, to Ubuntu and Kubuntu.

The installation of these systems requires that you install first Windows 8 on free space before the other systems.


Maybe zeroing out the MBR could help? dd if=/dev/zero of=/dev/sdX bs=512 count=1. I don't know how to do it for a GPT disk. After that, you could try the command line way: create the partition table in parted and then create the partitions with mkfs -t type /dev/sdXn.


Windows 8 comes with a protected partition for security reasons. I believe it's called EUFI. You need to disable the protection in the BIOS (usually something like F2 or F11 at bootup.) This is the only thing you need to do in order to remove Windows 8 completely and install Ubuntu...

However, if you wish to dual boot, you need to be ready to work - because it's hard work. Take a look at this tutorial at intructables.com which I used to dual boot my newly bought laptop. I later on downgraded to Windows 7 by the way.

Good luck...


I suggest that you install a [persistent] live system with mkusb according to these links


Compressed image file with a persistent live system with mkusb


  • first wipe the first megabyte on the problematic drive with mkusb.

  • then run gparted and create the partitions you want, or let the installer of the operating system do it, if you are not sure how to do it with gparted.

If you want to dual boot with Windows, install Windows first, and install Ubuntu afterwards. Otherwise Windows will 'hi-jack' the bootloader location at the drive head end and you have to re-install the grub bootloader.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .