3

Installing with a command line or in the GUI gives both the same error message. Packages are only fot AMD64 architecture not for ARM64

I only can find a .deb file for the amd64 processor. How can i install chrome?

2
  • I suspect you'll have to ask Google to release it. Chrome was ready to go more than a year ago (on arm it was written), however google have opted to not release it (it's closed source code built on the open source chromium browser). You may need to use another browser until you've persuaded google to package it for arm64.
    – guiverc
    Aug 28 '20 at 8:50
  • As guiverc mentioned, unless Google releases it, you cannot. Firefox works just fine. If you "need" the same engine as chrome uses, you can install chromium with sudo snap install chromium
    – marosg
    Aug 28 '20 at 8:55
1

Chrome is only compiled/distributed for x86 processors but you should be able to use the open source project, Chromium, that Chrome is based upon. You can install it by doing apt install -y chromium-browser

0

I also had this problem a few days ago mate. Can't install Chrome on my Debian 10 Buster (official) after many .debs tryied.

With some research i reallized that built Debian it's Chromium and it's a Chrome substitute, so i ended up to give up

0

You just said that you tried to install chrome from terminal. But, how can we know that which command you tried..? I actually install chrome by following steps.

sudo snap install chromium

There's another way to install chrome. Visit the link and download chrome with extension .deb

cd Downloads
sudo dpkg -i google-chrome-stable_current_amd64.deb
1
  • Question clearly asks for solution to install Chrome on arm64 not amd64. You have given command to install amd64 package.
    – Uttam
    Sep 11 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.