4

Ubuntu 20.04.1 LTS / XFCE / Dell Latitude 3460 recently upgraded from Ubuntu 18.04.

(1) After suspend first wakes up to an Unlock screen with a simplified log-in window (with just one Unlock button and without Switch User and Cancel buttons).

(2) Then, after entering a password, it proceeds to another Unlock screen (with a complete set of buttons: Switch User -- Cancel -- Unlock), which does not allow typing anything in the password box. The only option available is to cancel the action or to ask for switching the user.

After choosing this latter option, the system goes back to step 1 (the first login screen, which allows entering the password), then again to step 2 (another login screen which is again corrupted the same way as described above).

The problem repeats steadily.

killall light-locker (suggested here) which worked for me under 18.04 works no longer.

The only solution that worked so far is to log in from a tty1 or other text console and killall lightdm. The solution is hardly acceptable, though, because it effectively eradicates the previous session and I have to re-run all the applications I need.

I've read on the problems with nvidia drivers but it does not seem to be the case here:

 $ lspci -v | egrep -i --color 'vga|3d|2d'
 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09) (prog-if 00 [VGA controller])

UPD: loginctl unlock-session with an appropriate session ID does not work either.

I would be happy to hear any suggestions on the possible ways to diagnose and solve the problem.

1

2 Answers 2

3

Making explicit the solution that was proposed here. I was able to solve the issue by running the following commands:

sudo apt purge light-locker
sudo apt install --reinstall xfce4-screensaver
1

It seems that I have found a solution (even though I am not sure about the intrinsic mechanisms involved). Following a suggestion here I've typed the following in the terminal (ctrl+alt+t for terminal or ctrl+alt+F1 for a text console):

 sudo nano /etc/systemd/logind.conf

Then I uncommented the lines:

 HandleSuspendKey=suspend
 ...
 HandleLidSwitch=suspend

Then I saved the file and quit nano. Then I entered

 systemctl restart systemd-logind.service

Now the laptop, for some reason, does not respond to the lid closed but wakes up perfectly well after using GUI suspend (tried for three times).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .