1

Recently, my computer "upgraded" the Chromium deb-package to a snap on its own.
Not that I had wanted it, I had in fact uninstalled snapcraft.
I have read of this latest crap move by Canonical, so I was not surprised when snap reinstalled itself (unwantedly and without asking).
But so far, it seemed to be working, so I didn't mind (after having blocked snap-refreshes on metered-connections).

However, I just wanted to watch a china-uncensored youtube video
5 seconds ago - and - no sound...
The sound is working. System sounds work, vlc has sound, and with Firefox, sound works, too.
It used to work with the Chromium deb-package as well.

This seems to be a snap issue.
Is there any way I can debug this ?
Any way to view whatever log file to find out what goes wrong ?
Or any ideas towards problem resolution ?

(I'm running KDE-Plasma as root, so /usr/bin/pulseaudio runs with --system - I suspect that might be the problem)

4
  • 2
    IMO switch to Firefox. The Ubuntu community has decided it is not worth the time to be forced to constantly audit a browser (a LOT of work) from a developer that ultimately is not really prioritized with open source and freedom. The community can better allocate resources. See: ubuntu.com/blog/chromium-in-ubuntu-deb-to-snap-transition
    – Nmath
    Commented Aug 26, 2020 at 22:33
  • @Nmath: I'm already doing this with Firefox Developer Edition :)
    – WitchCraft
    Commented Aug 26, 2020 at 22:41
  • Is Google Chrome not an option? If not, there is this link for installing Chromium via alternate sources (from Mint, which disables snapd on install): linuxmint-user-guide.readthedocs.io/en/latest/chromium.html Commented Aug 26, 2020 at 22:57
  • 1
    Remove the snap version and install the .deb version. I have directions here if you need them.
    – KGIII
    Commented Aug 26, 2020 at 23:46

1 Answer 1

0

There seems to be a bug/feature in the snap version of chromium: even if you unset XDG_RUNTIME_DIR, it re-sets it when it runs, causing problems with pulseaudio if you're not using the standard XDG settings (this can be confirmed by looking in /proc//environ). Installing the latest Google Chrome (not Chromium) seems to fix this issue, so it looks like snap is doing something that it shouldn't.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .