1

Ubuntu 20.04 on HP Probook x360 435 G7 Can't resume after suspend as Screen not turned on

The laptop does not resume after suspend on HP Probook x360 435 G7 laptop, running Ubuntu 20.04. After pressing power button, the screen remains blank although the keyboard lights start glowing.

Pressing Alt-Ctrl-F1 or F2/F2, etc. does not yield any response on screen. However pressing Alt-Ctrl-F3 + Alt-Ctrl-Del does reboot the system. Also since keyboard is working, typing the login password (on a blank screen!) and then running "sudo reboot" also works! So apparantly only the screen is not getting turned on.

Contents of /var/log/pm-suspend.log can be found here.

I've tried suspend by using the suspend button in settings-menu and using $sudo systemctl suspend

Processor is AMD Ryzen 7 4700U with Radeon Graphics

$ cat /proc/cpuinfo  | grep AMD
model name  : AMD Ryzen 7 4700U with Radeon Graphics
$ sudo dmidecode -s bios-version
S80 Ver. 01.01.04

Kernel version is 5.4.0-42-generic

$ uname -a
Linux abhijit-laptop 5.4.0-42-generic #46-Ubuntu SMP Fri Jul 10 00:24:02 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

RAM is 8 GB

$ free -m
              total        used        free      shared  buff/cache   available
Mem:           7420        1946        3721         166        1752        5027
Swap:         15257           0       15257

Swap Partition is 15 GB

$sudo swapon 
NAME           TYPE       SIZE USED PRIO
/dev/nvme0n1p7 partition 14.9G   0B   -2

Also,

$ cat /etc/systemd/logind.conf  | grep -i suspend
#HandleSuspendKey=suspend
#HandleLidSwitch=suspend
#HandleLidSwitchExternalPower=suspend
#SuspendKeyIgnoreInhibited=no

Also

$ cat /sys/power/state
freeze mem
$ cat /sys/power/disk
[disabled]
$ cat /sys/power/mem_sleep 
s2idle [deep]
$ cat /sys/power/resume
0:0

Secure-Boot is enabled, and that is why perhaps I don't see a "disk" in cat /etc/power/state. After Disabling secure-boot the "disk" option is visible in /etc/power/state , and hibernation works, but at the cost of reduced display resolution -- and even then suspend does not work.

Also,

$ sudo lshw -c video
[sudo] password for abhijit: 
  *-display UNCLAIMED       
       description: VGA compatible controller
       product: Renoir
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:04:00.0
       version: c2
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:d0000000-dfffffff memory:e0000000-e01fffff ioport:2000(size=256) memory:e0700000-e077ffff

and

$ lsmod | grep amd
edac_mce_amd           32768  0
kvm_amd                98304  0
ccp                    86016  1 kvm_amd
kvm                   663552  1 kvm_amd

Also,

$ lspci  | grep -i intel
01:00.0 Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a)

and

$ lspci  | grep -i audi
04:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Device 1637
04:00.5 Multimedia controller: Advanced Micro Devices, Inc. [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor (rev 01)
04:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) HD Audio Controller

and

03:00.0 Non-Volatile memory controller: SK hynix Device 1339

$sudo pm-hibernate 
$ echo $?
1
$ sudo pm-suspend
$ echo $?
128

I've tried these:

1) Following this article Ubuntu 19.04 freezes after suspend I tried

/etc/default/grub setting
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash resume=UUID=646c69bc-782d-4bcb-be49-f4308c37d358 nouveau.modeset=0"

2) Following the advice on HP Notebook 17-y020ca under XUbuntu 16.04 unable to resume from suspend

pm-suspend --quirk-radeon-off

3) Installed following packages

$ dpkg -l | grep amdgpu
ii  libdrm-amdgpu1:amd64                          2.4.101-2                             amd64        Userspace interface to amdgpu-specific kernel DRM services -- runtime
ii  ricks-amdgpu-utils                            2.6.0-1                               all          AMD GPU performance adjustment and monitoring
ii  xserver-xorg-video-amdgpu                     19.1.0-1                              amd64        X.Org X server -- AMDGPU display driver
ii  xserver-xorg-video-amdgpu-hwe-18.04           3:14.5                                amd64        Transitional package for xserver-xorg-video-amdgpu-hwe-18.04

But all that did not help.

I'll be willing to share more logs and configuration file details. Can anybody help?

  • Please accept your answer as the correct one by clicking on the gray check mark 🗸 and turn it green ✅. This will indicate the problem is solved and it may help others. – user68186 Oct 22 '20 at 17:02
2

The problem is solved after

  • installing the latest kernel using ubuntu-mainline-kernel.sh from https://github.com/pimlie/ubuntu-mainline-kernel.sh
  • disabling secure boot (otherwise the machine does not boot, and it keeps asking for a kernel signature)
  • removing blacklist amdgpu from /etc/modprobe.d/blacklist.conf
  • running sudo update-initramfs -u
  • Good work solving this! Apologies for a question here. (If improper, please re-direct me.) Can you re-cap what is working on your HP Probook w/ Ubuntu 20.20? Was it the 5.7 kernel that you installed? – John in SF Sep 29 '20 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.