I have 3 days trying to install Windows 10 and Ubuntu 20 in dual boot. I researched and found that windows should be installed first and then Linux. I already asked in Super User forum and tried this answer too without success

I already have Windows 10 installed in BIOS mode = UEFI.

I have BIOS with UEFI enabled.

I created a bootable USB using Rufus from an Ubuntu iso file with the following parameters

  • GPT and UEFI (non CSM)
  • FAT32.

Now, when I try to boot from bootable USB, appears a yellow shell that I found is named EFI shell and I'm stuck in how to fix this.

Note: In case it matters, the motherboard is American Megatrends a kind of old.

Thanks in advance for any help.

  • Did you disable secure boot in UEFI?
    – Raffles
    Aug 25, 2020 at 22:10
  • @Raffles Hi, I don't find that option in the BIOS and I followed a way to disable secure boot from Windows and doesn't appear either. I'm not sure what other workaround to try
    – Ger Cas
    Aug 26, 2020 at 0:13
  • @Raffles I've just tried to make a bootable USB with Rufus using a Puppy Linux iso named bionicpup64-8.0-uefi.iso with parameters GPT, EUFI and FAT32 and I got the installation menu of Puppy Linux. Then I tried to do the same process with the Ubuntu iso ubuntu-20.04.1-desktop-amd64.iso but with Ubuntu bootable USB boots directly on Windows10. What could be different between puppy Linux iso and Ubuntu iso?
    – Ger Cas
    Aug 26, 2020 at 0:23
  • I suggest to follow the guide here and then follow the steps here. Ubuntu 20.04.1 will be the same steps as 17.04
    – Raffles
    Aug 26, 2020 at 8:13
  • 1
    @Raffles Thanks for your help. Testing and testing I was able to install Elementary OS. Any flavour of Ubuntu fails. Elementary OS is based on Ubuntu I think but it works I don't know why.
    – Ger Cas
    Aug 26, 2020 at 22:17


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.