2

I recently noticed that my Dell laptop is overheating because the fan stops. I've read almost all posts on the internet related to fan control, anything related to i8kctl and lm-sensors.

The laptop runs dual boot and there's no issues when I'm running Windows 10, it only happens on Ubuntu 20.04.1.

What I've found out is when I run command sudo pwmconfig, I'm getting this output:

Found the following PWM controls:
hwmon5/pwm1           current value: 0

Giving the fans some time to reach full speed...
Found the following fan sensors:
hwmon5/fan1_input     current speed: 0 ... skipping!


There are no working fan sensors, all readings are 0.
Make sure you have a 3-wire fan connected.
You may also need to increase the fan divisors.
See doc/fan-divisors for more information.

It suggests that my fan sensor is having some kind of connectivity problem. However the fan turns on sometimes for few seconds, then dies again. At the same time, it runs just fine on Windows, so imo this is not the problem. I've updated BIOS, cleaned and tested the fan so my guess it's a Linux problem.

I tried to manually control the fan with i8kctl, but it didn't work for me either. Can anybody help me deal with it?

2
  • Welcome to AskUbuntu, does this help? askubuntu.com/questions/1227489/… Aug 25, 2020 at 21:21
  • I have a similar issue with my Acer Aspire V3 running Ubuntu 20.04. Sometimes CPU temperature reaches 90 ºC while the fan is blowing at a very low speed.
    – jap1968
    Dec 8, 2020 at 21:50

1 Answer 1

0

Thank you @sadaharu-wakisaka ! It indeed helped me :)

First, I had to disable dell-bios:

git clone https://github.com/TomFreudenberg/dell-bios-fan-control.git
cd dell-bios-fan-control
make
sudo ./dell-bios-fan-control 0

Then use i8kutils to set up the fan:

git clone https://github.com/vitorafsr/i8kutils
cd i8kutils
make
sudo ./i8kctl fan 2 2

Now I'm not sure if there's anything I could do to automate it, so every time I want to control the fan I need to disable dell-bios with sudo ./dell-bios-fan-control 0 and then sudo ./i8kctl fan 2 2. It works every time! Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.