I am using Ubuntu 20.04.1. Recently (I haven't noticed exactly when), the graphic login screen of Ubuntu started showing the login names (the first field in the /etc/passwd file) instead of the full user names as set in the 5th (comment) field in the /etc/passwd file.

A copy of my Ubuntu user definition from /etc/passwd is given below:

fedon:x:1000:1000:Fedon Kadifeli:/home/fedon:/bin/bash

For this user, I am expecting the full name Fedon Kadifeli to be displayed on the graphical login user selection screen at the right of the account picture. However, the login name fedon is displayed instead. However, after I select the user and switch to the graphical password entry screen, the full user name of the selected login name is displayed (as expected).

How can I set Ubuntu to display the full names in the login screen again?


  1. I have a test (virtual) system with exactly the same Ubuntu version and it displays the user names correctly in the login screen. I need to find the difference between these the two systems. The user entries in /etc/passwd are exactly the same on both systems. I have checked Settings -> Users on both systems and the user definitions are also the same.

  2. I tried to change the entries in /org/gnome/login-screen/ with dconf-editor. However, they have no effect. I guess the changes are made for the current user, whereas a system-wide configuration should be needed for the login screen!

  3. I have also looked at: https://help.gnome.org/admin/system-admin-guide/stable/login.html.en , but I found nothing useful.

May be important:

  1. There is an "accessibility" icon (the little guy with open arms) on the log in screen. I have not enabled any accessibility option; all options are in their defaults which is off. However, when I enable the Large Text option, the text becomes larger and the login names change to full user names. Even after I disable the Large Text option back to its original off position, the text reverts back to its normal (smaller) size, but the full user names stay on the screen (exactly as I want them). However, this state is not preserved after reboot.

  2. I have a feeling that this problem may be related to another one observed on my system: After system boot, many processes belonging to `gdm` user are created

  • what if you change your username and full name? in /etc/passwd?
    – j0h
    Sep 2, 2020 at 0:50
  • I haven't tried to change the login name (the first field in the /etc/passwd file), since this would result in many problems. But, I did change the full user name (as set in the 5th comment field in the /etc/passwd) with nothing changing.
    – FedKad
    Sep 2, 2020 at 7:09
  • 1
    I can confirm this is an active issue, I see the same behavior with my devices. I have two 20.04 machines, both installed about the same time, both up to date and with basically identical setup. The laptop, with a 1080 screen, shows my full name. The desktop, on a 1200 screen, shows my username. No obvious config differences I can see, and if anything the desktop has a higher resolution, so name length should not be an issue (also my name + last name are not particularly long). Subscribing to this question in case an answer comes up. Oct 1, 2020 at 6:18

4 Answers 4


Well, not sure you'll be happy to learn this, but there is what appears to be an active bug that suggests that it's the length of the user name that determines whether to display full name or username, details here: https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1841810

I'd recommend you test this on your installation to confirm. I can tell you that the full name "John Doe" on my installation (running Gnome on Ubuntu 20.04.1) does show just fine in gdm3.

  • Thank you for your response. As I mentioned in my original post, I have two systems which are fully up-to-date with Ubuntu and on both systems I have two (login) users with exactly the same login names and full user names. One of these systems is working as expected, the other is not. And I want to find what makes them different in this respect. In any case, to test your answer in my problematic system, I changed the full user name from Fedon Kadifeli to FedKad, but nothing changed. So, I cannot accept this answer.
    – FedKad
    Aug 29, 2020 at 16:28
  • And I think that it is also not a screen resolution difference.
    – FedKad
    Aug 29, 2020 at 16:36

After the regular Ubuntu 20.04.1 system update today this problem was fixed. I suspect it is the mutter package and the related libraries that were updated from 3.36.4 to 3.36.6 that fixed that problem. The current state of the system is something like this:

$ apt --installed list  | grep mutter

gir1.2-mutter-6/focal-updates,now 3.36.6-1ubuntu0.20.04.2 amd64 [installed,automatic]
libmutter-6-0/focal-updates,now 3.36.6-1ubuntu0.20.04.2 amd64 [installed,automatic]
mutter-common/focal-updates,focal-updates,now 3.36.6-1ubuntu0.20.04.2 all [installed,automatic]
mutter/focal-updates,now 3.36.6-1ubuntu0.20.04.2 amd64 [installed,automatic]

Now, the full user names, instead of the short login names are displayed even when I select "Large text" or normal text from the accessibility menu.

If somebody had the same problem and it is or not fixed now, after the latest Ubuntu 20.04.1 update, please comment.

  • 1
    Indeed, this update has solved the issue for me as well. Thanks for posting! Oct 18, 2020 at 9:26

You can drop to a TTY and log in. You can then run the following:

sudo apt purge gdm3 && sudo apt install gdm3 && sudo systemctl enable gdm3 && sudo systemctl start gdm3

The above commands will remove GDM3 (login screen) completely from your system, install it again and start GDM3.

If is still doesn't work, you can report the bug at https://bugs.launchpad.net/ubuntu/+source/gdm3/+filebug, or by running the following in the terminal:

ubuntu-bug gdm3
  • Thanks for the response. I did the steps as you specified. However, nothing changed (I also tried after rebooting my system). However, there is something that may help: There is an "accessibility" icon (the little guy with open arms) on the log in screen. I have not enabled any accessibility option; all options are in their defaults which is off. However, when I enable "Large Text", the text becomes larger and the login names change to full user names. Even after I disable "Large Text" back to original "off" position the full user names stay on the screen (as I want them).
    – FedKad
    Sep 1, 2020 at 14:06

You could always try installing another display manager like lightdm or kdm.... (assuming you are currently using gdm).... Being that lightdm is running on my MATE system, and yours and mine virtual systems seem to be behaving similarly.

For comparison:
These all worked for me. I'm using Mate 20.04.1 LTS(host), running a Flashback VM in virtual box (20.04.1 LTS).... Both of my systems display the same behavior...

a) Editing /etc/passwd takes effect immediately... Tested by locking the screen and/or switching user. The full user name shows at the login. Effect also seen immediately in the name change at "power button/switcher" menu on the panel.

b) Using sudo chfn -f "Ladies Love my Username" <username> same success.

c) Using sudo usermod -c "Ladies Love my Username" <usermame> same success.

d) Using the GUI under System Settings --> Users to edit the user name... same success

  • Thanks for your response. But, my intent is to find the reason of what is causing this behavior in my system, where another similar system does not have this problem.
    – FedKad
    Sep 2, 2020 at 7:11
  • Agreed.... I'd still be curious, if I was troubleshooting, to know if the host system behaved the same way with a different display manager... (I assumed your VM was hosted on the system with the problem, is that the case?)
    – WU-TANG
    Sep 2, 2020 at 13:19
  • The system with "the problem" is a physical notebook; while the system without the problem is a Virtual Box virtual machine hosted on the same notebook.
    – FedKad
    Sep 2, 2020 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.