When trying to execute the follow in a Terminal window:

        -D CMAKE_INSTALL_PREFIX=/usr/local
        -D OPENCV_EXTRA_MODULES_PATH=~/projects/cv2/opencv_contrib/modules
        -D PYTHON_EXECUTABLE=~/env/bin/python
        -D BUILD_EXAMPLES=ON …/opencv

I get an error message on the last statement saying “source directory does not exist”. What should be put in the place of the two …/opencv?

When I tried the command echo $(which python), I received the message /home/jetson/env/bin/python.

What is the issue and how do i solve it?

1 Answer 1


If you specify a directory as parameter for cmake, it will change into that directory and searches for the CMakeLists.txt file. See also the cmake manpage for more information.

In your command, you specified and invalid directory: …/opencv. Three dots is not a valid directory in Linux. You propaly need to change it into ../opencv to work. But It really depends, where the opencv folder is

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.