0

I have a Dell Latitude 6430u dual boot Xubuntu 18.04 and Windows 7

Today I tried upgrading to 20.04 but during the process I got some error messages which said something to the effect that the upgrade did not finish and that the system may be unstable. I took screenshot of those messages (but I cannot access anymore as I left them on my desktop folder) and proceeded to shutdown normally.

Hours later I tried to boot up and I only see a black screen. I can boot into windows 7 without a problem. Next time I try to boot I get something that looks like a command shell and one of the error messages says "Unable to mount root fs on..."

Then I try booting into an older Kernel. It still doesn't work but this seems to get me a little further: I am able to see the Xubuntu logo and the spinning wheel beneath it. But just a black screen afterwards.

I tried booting in recovery mode on an older kernel and do dpkg (repair broken packages) but that didn't seem to fix anything.

Following this post I did sudo apt-get update and sudo apt-get upgrade but I got the following error message: "1407 not fully installed or removed" This was at the same time that it asked me if I wanted to continue. I chose no.

That's where I stand now and I'm out of ideas. I would appreciate any help.

0

Boot a live DVD or thumb drive and install it from there?

Make sure you have a backup of your files. Of course, you may not be able to get to them if you don't do backups.

2
  • So do a fresh install? I did backup my files just before attempting to upgrade but I was wondering if I could still salvage the situation and avoid a fresh install. – user87317 Aug 23 '20 at 3:24
  • From a personal perspective, I almost always reinstall from a live cd. Historically works better for me. My files backup on a regular basis. – UnqtiousDude Aug 24 '20 at 15:48
0

I would try to run a sudo apt dist-upgrade and answer YES to the question, whether I want to continue.

If this doesn't work, you may try sudo dpkg --configure -a instead.

Hopefully, it will complete the installation of 20.04.

Then I would run sudo apt autoremove to remove old packages that are no longer needed.

3
  • I just tried this and unfortunately it did not work. I get a lot of "dpkg: error processing package" and one error at the end that reads "E: sub-process /usr/bin/dpkg returned an error code (1)" – user87317 Aug 23 '20 at 14:21
  • I added another alternative. – To Do Aug 23 '20 at 16:07
  • After running dpkg I caught a line that said "error running python..." before disappearing. The last line says " processing was halted because there were too many errors" – user87317 Aug 23 '20 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.