0

I am on Ubuntu 20.04 (Kernel: 5.4.0-42-generic) and have been experiencing high CPU usage (30-40%); even when I'm just looking at my desktop without any applications open in the background.

I have recently made two changes to my system:

  1. Upgraded RAM (Previously had 4GB, added an 8GB stick)
  2. Installed Windows 10 (Dual-Boot)

And I believe it is after I dual-booted windows I'm facing this issue. I can hear my fans all cranked up, this wasn't an issue before.

Update:

I also updated the BIOS after installing windows, maybe that is the cause of the issue?

enter image description here enter image description here

4
  • Execute top on terminal and add the screenshot of that. – Akib Azmain Aug 22 '20 at 12:37
  • Have updated the post with the result of top command – Vandit Goel Aug 22 '20 at 13:48
  • 1
    Is Secure Boot disabled in your BIOS? – heynnema Aug 22 '20 at 14:05
  • @heynnema I just checked and somehow it got enabled after a bios update I did. I've now disabled it and the CPU usage is back to normal! – Vandit Goel Aug 22 '20 at 14:21
1

System Monitor

In System Monitor enable All Processes for a more complete look...

enter image description here

Or use the top command in the terminal.

Memory

In order to take the speed advantage of memory interleaving, memory DIMMs should always be configured in equal size/type DIMM pairs. With 4G, you should have either added another 4G DIMM, or replaced it with two 8G DIMMs.

Windows

  • boot into Windows
  • open the Power control panel
  • choose change what the power buttons do
  • choose change options that are unavailable
  • uncheck fast startup
  • close the Power control panel
  • open an administrative command prompt window
  • type powercfg /h off
  • type chkdsk /f c:
  • approve to run chkdsk at next reboot
  • type chkdsk /f x: (replacing "x" with drive letters of other visible NTFS partitions)
  • reboot into Windows to let chkdsk run on drive C:

Update #1:

From the comments... Turned off Secure Boot in the BIOS, and it's working fine now.

1
  • as suggested by this comment, my secure boot was enabled. After disabling it everything seems to be normal. – Vandit Goel Aug 22 '20 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.