16

I'm running Ubuntu 20.04 on an ASUS X99-E-10G WS w/ an NVIDIA 1080Ti and an LG 4k 32" monitor which persistently gets recognized as 27".

When I log in, the text of certain UI elements is ~2x the normal size. After I go to settings/universal access and turn large text on and then off again, everything is the normal size I expect.

Screenshot after logging in Screenshot after logging in

After turning "large text" on After turning "large text" on

After turning "large text" off After turning "large text" off

How do I get the conditions I have after cycling the "large text" feature to be present immediately after booting?

I have the 440 version of NVIDIA's drivers installed.

4
  • when you log out and login back is that still happening?
    – UnKNOWn
    Aug 21 '20 at 14:39
  • This literally just happened to me too. Everything was fine, rebooted, now I have this. I'm running Nvidia 450, but I don't think it's driver related.
    – Matt Green
    Aug 21 '20 at 15:32
  • 1
    it happened to me as well yesterday. Never used nor fractional scaling neither accessibility options. What I do at every boot is to temporarily gsettings set org.gnome.desktop.interface text-scaling-factor 1.01 and immediately after come back to gsettings set org.gnome.desktop.interface text-scaling-factor 1.00. Consider that initial value is still 1.00, but only with this trick I'm able to retrigger the correct scaling. Seems that also this user has a similar issue: askubuntu.com/questions/1269090/… Aug 22 '20 at 16:06
  • Many people are facing issues with scaling on 4k. bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/… claims that this has been fixed a few days ago, but it does not work for me yet.
    – Christians
    Aug 24 '20 at 14:46
3

Looks like this bug affects a few of us with nVidia card, but with Intel GPU as well. There is an open bug thread already here: https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/1892440

A temporary fix mentioned in comment #17 fixed the issue for me, until the fix will come out. Simply donwgrade libmutter package and put it on hold.

sudo apt install libmutter-6-0=3.36.1-3ubuntu3 gir1.2-mutter-6=3.36.1-3ubuntu3
sudo apt-mark hold libmutter-6-0
1
  • As of now, Oct 7, the bugfix has been released. Please comment and check to see if the issue has been fixed. If not, report a new bug. Oct 7 '20 at 16:09
0

On the login screen, top right, there is an icon of a person with arms outstretched. That is the accessibility menu. Choose "Large text" there.

As far as I know, this will survive a reboot.

1
  • This didn't make any difference for me. Large text was off in that menu, and the settings show small text when I login. But still massive top bar, and huge icons in the app menu.
    – Matt Green
    Aug 21 '20 at 15:34
0

you can install gnome-tweak-tool and manage your font style,font size,extantions and ...

sudo apt install gnome-tweak-tool
0

I had the same issue today on a similar machine with a 4k monitor. Previously I had to use a combination of large text in accessibility and font scaling in gnome tweaks to get a usable display.

My solution was to turn on fractional scaling (which had never worked before with my nVidia card) and turn off large text and return font scaling to 1.00. These settings survived a reboot. The only difference is that the login screen fonts are larger than they had been previously but that is an improvement.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.