2

My work PC has an Intel HD Graphics 5500, it is a Lenovo t450.

DaVinci Resolve 16 doesn't work on it. I'm using Ubuntu Studio 20.04 LTS. I've tried to install makeresolvedeb, but it still doesn't work and shows me this message:

DaVinci Resolve could not find any OpenCL capable GPUs. Would you like to review and update your DaVinci Resolve Hardware Configuration?

Screenshot of DaVinci Resolve error

Any help?

1
  • Update Now DaVinci Resolve 17 works onUbuntu Studio 20.04 LTS, but medias wont import. Any solution to this? I already tried all codec and format of video. BTW thanks for the help.
    – eriz
    May 28 at 10:36
2

Now I would like to post this as a comment but I can't yet... Here are some steps that you can start with:

  • Do you have libOpenCL.so installed and available to the app? see if there's anything missing in ldd /opt/resolve/bin/resolve | grep OpenCL
  • If it is not installed, you might want to try installing ocl-icd-opencl-dev, as described here: How to install libOpenCL.so on ubuntu, since this package is also listed as a prerequisite for installing davinci resolve in this article: https://www.fosslinux.com/24381/how-to-install-davinci-resolve-on-ubuntu.htm
  • Make sure libOpenCL.so is in your ldconfig cache: ldconfig -p | grep OpenCL, if not, update it with ldconfig, then run sudo dpkg-reconfigure davinci-resolve

If that doesn't help, this article (where I also found most of the other information) lists some more things you can try: https://bashbaug.github.io/opencl/2019/07/06/OpenCL-On-Linux.html (see section "Troubleshooting OpenCL on Linux")

1
  • Both the first and third command output something. I tried the install from the second point but all it did was uninstall nvidia-opencl-dev and install ocl-icd-opencl-dev which didn't make DaVinci work
    – xjcl
    Dec 30 '20 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.