0
$ cat /etc/fstab

gUID=b8e93e66-9575-44f9-8ef5-97665713b7e3 / ext4 defaults 0 0
/swap.img       none    swap    sw      0       0
//192.168.1.103/share /mnt/Media cifs username=guest,uid=1000 g g

Hi all

I am trying to mount a Buffalo Linkstation on my Ubuntu 18.04 VM.
The above is my /etc/fstab, but whenever I run sudo mount -a I get parse error at line 4 -- ignored. I followed the instruction on this webpage: https://mginternet.wordpress.com/2012/01/05/mounting-a-buffalo-linkstation-share-on-ubuntu/

and it seemed pretty correct. The linkstation does have the share folder and I can access it on windows just fine.

The IP address is reachable from my VM as well via ping.

I am at a loss as to what could have caused this.

4
  • I see two typos on line 4.
    – user535733
    Aug 20 '20 at 3:54
  • lol ok what is it because I am not seeing them. the share is there, the Media is correctly spelled, the rest is copy pasted and doesn't seem to be spelled wrong
    – D.Zou
    Aug 20 '20 at 3:59
  • Look harder. Compare the line in the the instructions with your fstab line 4, char by char.
    – user535733
    Aug 20 '20 at 4:01
  • Your line ends with g g instead of 0 0. Surely that would cause errors.
    – Zanna
    Sep 1 at 5:56
0

I have a ls220de. Maybe this can help you, This is my config:

//192.168.0.XXX/share /mnt/z cifs username=admin,password=ThePassword,vers=1.0,auto,x-systemd.automount,uid=1000,guid=1000
0
//192.168.0.XXX/share /mnt/z cifs username=admin,password=ThePassword,vers=1.0,auto,x-systemd.automount,uid=1000,guid=1000

This worked for me on Ubuntu 20.04

The key point is the option vers=1.0

If you see dmesg, you can see that this is recommended (at least in my case)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.