2

free -m

total used free shared buff/cache available
Mem:           7953        3334        1265          61        3353        4262
Swap:          6047           0        6047

sudo lshw -c memory

*-firmware                
       description: BIOS
       vendor: American Megatrends Inc.
       physical id: 0
       version: 4022
       date: 08/08/2018
       size: 64KiB
       capacity: 16MiB
       capabilities: pci apm upgrade shadowing cdboot bootselect socketedrom edd int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int9keyboard int14serial int17printer acpi usb biosbootspecification uefi
  *-memory
       description: System Memory
       physical id: 23
       slot: System board or motherboard
       size: 16GiB
     *-bank:0
          description: DIMM DDR4 Synchronous Unbuffered (Unregistered) 2400 MHz (0.4 ns)
          product: KHX2400C15/8G
          vendor: Kingston
          physical id: 0
          serial: ED3FC90A
          slot: DIMM_A1
          size: 8GiB
          width: 64 bits
          clock: 2400MHz (0.4ns)
     *-bank:1
          description: DIMM DDR4 Synchronous Unbuffered (Unregistered) 2400 MHz (0.4 ns)
          product: KHX2400C15/8G
          vendor: Kingston
          physical id: 1
          serial: ECBA5B02
          slot: DIMM_B1
          size: 8GiB
          width: 64 bits
          clock: 2400MHz (0.4ns)
sudo dmidecode -s bios-version
4022

I started with 8GB RAM on my computer. Then I installed an extra 8GB module but Ubuntu didn't recognize total RAM as 16GB, but still 8GB. The strange thing is that when I enter the BIOS it recognizes both 8gb modules(DIM_A1 and DIM_A2 slots) but in total RAM it still 8gb. Also from first command it shows 8gb RAM, but second one it is showing both modules (16gb)...

Motherboard : Asus Prime A320m-K CPU : AMD Ryzen 5 2600

5
  • 1
    Boot into memtest86+ does it see all the RAM?
    – waltinator
    Aug 19, 2020 at 20:48
  • @waltinator It shows 8gb...Also I tried to reorder modules and CPU eject then insert but none where successful. Aug 19, 2020 at 21:28
  • What processor do you have? Tell me your exact computer or motherboard model #, and show me sudo dmidecode -s bios-version.
    – heynnema
    Aug 20, 2020 at 0:04
  • By posting a picture of text, you make it impossible for potential helpers on phones, or text terminals. to see your text. Rather, copy and paste the text into your Question, select it and use the {} formatting tool.
    – waltinator
    Aug 20, 2020 at 3:57
  • @heynnema it shows 4022. Also my motherboard is Asus Prime A320m-K. Thank you, I changed post. Aug 20, 2020 at 6:28

2 Answers 2

0

BIOS

Asus Prime A320m-K

You have BIOS 4022 from 9/7/2018.

There's a newer BIOS available, version 5602, dated 7/27/2020, and it can be downloaded from here.

Note: Confirm that I have the correct web page for your motherboard.

Note: Have good backups before updating the BIOS.

Memory

AMD Ryzen 5 2600

Ryzen processors are notorious for memory compatibility issues.

We need to test your RAM, but we do it after the BIOS update.

Go to https://www.memtest86.com/ and download/run their free memtest to test your memory. Get at least one complete pass of all the 4/4 tests to confirm good memory. This may take many hours to complete.

CPU Support: https://www.asus.com/us/Motherboards/PRIME-A320M-K/HelpDesk_CPU/

Memory Support: https://www.asus.com/us/Motherboards/PRIME-A320M-K/HelpDesk_QVL/

13
  • I upgrade BIOS to the latest (5602), but right after that my Ubuntu won't boot. Blank screen, also keyboard, mouse doesn't working. Grub is not showing. I backup everything, but now I don't know what to do. Aug 20, 2020 at 22:11
  • @mmiroslav13 Sorry about your troubles. Do you even get the BIOS splash screen on your video monitor? Contact Asus Support at their web site, or via phone, asap. You could try removing AC power, remove the motherboard backup battery for 30 minutes, return the battery to its socket, replug AC, and retry.
    – heynnema
    Aug 20, 2020 at 22:26
  • @mmiroslav13 Asus has CHAT available at the BIOS web site. See link in my answer.
    – heynnema
    Aug 20, 2020 at 22:48
  • @mmiroslav13 See asus.com/us/Motherboards/PRIME-A320M-K/HelpDesk_Knowledge, and click the BIOS/firmware filter on left.
    – heynnema
    Aug 20, 2020 at 23:49
  • @mmiroslav13 Did you get it all working? How did you resolve the BIOS problem? Is your RAM all being seen now?
    – heynnema
    Aug 21, 2020 at 14:18
0

My answer is: the issue is probably due to bent contacts on the motherboard. Repair: Inspect the contacts on the CPU (usually OK) and on the motherboard and try to correct their form.

The story is: I had the same problem twice, once in the past with an Intel 10th gen,and recently with a Ryzen 7 2700, both on Gigabyte motherboards: BIOS recognized 2 pieces of RAM, but the CPU used only one. I tried all the suggestions above, then I started to doubt if there is no contact problem between motherboard and CPU. I opened the fan and the CPU. The CPU contacts were all OK. I then suspected that there might be some bent contacts on the motherboard side. In order to inspect them I had to take out the metal lever and the plastic perforated cover used to fix the CPU. And YES! There were a few contacts on the motherboard that were bent! I mended them using a magnifying glass and a needle.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .