1

I was trying to install geopsy software, but when I ran sudo make install the following error occured:

cd mseed/ && ( test -e Makefile || /usr/lib/qt5/bin/qmake -o Makefile /opt/geopsy-3.3.0/mseed/mseed.pro ) && make -f Makefile install
make[1]: Entering directory '/opt/geopsy-3.3.0/mseed'
[ -d /opt/geopsy-3.3.0/lib ] || mkdir -p /opt/geopsy-3.3.0/lib
cp '/opt/geopsy-3.3.0/lib/libmseed.a' and '/opt/geopsy-3.3.0/lib/libmseed.a' are the same file
make[1]: *** [Makefile:30: install] Error
make[1]: Leaving directory '/opt/geopsy-3.3.0/mseed'
make: *** [Makefile:152: sub-mseed-install_subtargets-ordered] Error 2

before I ran sudo make install, I ran sudo ./configure -prefix /path sudo make -j 2

Please help me fix this problem. I'm new on Ubuntu.

0

2 Answers 2

0

Ok, so you are talking about http://www.geopsy.org/download/archives/geopsypack-src-3.3.0.tar.gz .

Follow their guide http://www.geopsy.org/wiki/index.php/Installation:Linux .

To get it compiled use commands below:

sudo apt install qt5-default qttools5-dev-tools qtscript5-dev qtdeclarative5-dev \
libqt5svg5-dev g++ gfortran libfftw3-dev liblapack-dev zlib1g-dev

cd ~/Downloads
wget http://www.geopsy.org/download/archives/geopsypack-src-3.3.0.tar.gz
tar -xf geopsypack-src-3.3.0.tar.gz
cd geopsypack-src-3.3.0
./configure -prefix /opt/geopsy-3.3.0

make -j8
sudo make install
1
  • i used make -j 2 because of the total cores that i had. i've tried those commands but it still error Aug 24, 2020 at 5:51
0

To resolve this issue first try to install the make command. First and the most obvious installation method is to execute the following command:

sudo apt install make

However, yet an another alternative and probably also the solution you want is the installation of the entire development package build-essential which also includes the make command:

sudo apt install build-essential

In case the make command is still not found check whether the make binary executable exists:

 ls  /usr/bin/make
/usr/bin/make

Check if you can execute the command using a full path:

/usr/bin/make --version
GNU Make 4.2.1
Built for x86_64-pc-linux-gnu

Now, ensure the path to the make is a part of your executable shell path:

echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin

Now, you may try to reinstall the make command:

sudo dpkg-reconfigure make
1
  • The make version of mine is same as yours and the shell path is fine. I've tried all of those commands but it still doesn't work Aug 24, 2020 at 6:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.