1. Ubuntu 20.04 desktop installer: does not detect existing RAID configuration.
  2. Ubuntu 20.04 server installer: detects the existing RAID configuration but does not let me select boot disk. I am able select a USB disk as boot disk but not the actual hard disk as boot disk where I am installing the OS.

This leaves me no option to successfully install Ubuntu on my system. I have tried following possible solution but it did not work:

  1. Used mdadm to load RAID configuration in Ubuntu 20.04 live environment and then started the Ubuntu 20.04 installer which then successfully detected all the existing logical LVM on top of the software RAID. I am able to install Ubuntu 20.04 but on reboot RAID configuration is not loaded automatically.

If I can somehow select the boot disk with Ubuntu 20.04 Server installer, I think then I can install server and then use APT to install desktop environment.

I would appreciate any possible help to understand how to select boot disk with Ubuntu 20.04 server installer or make the Ubuntu 20.04 Desktop installer detect the existing software RAID.

1 Answer 1


Installing Ubunto Desktop 20.04.1

After some digging I got a bit more insight I want to share:

Removing the software raid by removing the harddisks allows to install Ubunto via the installer without a glitch. The ubunto installer does not work with software raids, while the installed ubunto system does. Then reconnect the harddisks of the software raid, and boot a live system (like parted magic). Copy the files to places on the raid and update all configuration files that connect to partitions.

Method in detail:

  1. Remove the harddisks that make up the raid.
  2. Do not add a harddisk - but NVMe SSD, otherwise the BIOS will attempt to reorganise the missing the software raid. I added an NVMe SSD installed Ubunto there. Just add anything you can install ubunto on. Make sure the root partition is not btrfs (I used ext4), as this will facilitate to copy the root partition to a software-raid partition. Using btrfs will add subvolumes that are cumbersome to copy (especially when using this filesystem for the root partition).
  3. Install Ubunto 20.04.1 from an USB stick. Make sure to use a /home partition during the install, located on the NVMe SSD Do not use BTRFS for the root partition.
  4. After the installation is complete start ubunto and install mdadm apt-get install mdadm
  5. After that, shut down the ubunto system and reconnect the harddrives that made up the software raid.
  6. Start Ubunto and edit /etc/fstab reconnect /home to the software raid partition
  7. Option: move ubunto partitions to the software raid The best option is that you boot using a live system that is not the installed ubunto version. 7.1 copy the content of all ubunto partitions to partitions (ideally of equal size) on the software raid 7.2 edit /etc/fstab and connect all partitions to the ones on the software raid 7.3 Use efibootmgr to update (or create) the BIOS entry to start the ubunto system from the raid (use UUIDs which you query with the command blkid)

Eventually it worked. I can run multiple linux distributions including ubunto on the software raid. It is kind of sad that ubunto does not support software raids, which do improve system stability and especially the ability to recover from HDD or SDD failures. The solution with the software raids allowed me to run several systems for more than 7 years with minimal changes.

Now some speculation as to what went wrong: I gave up looking for the source code of the installer and the grub version that comes with it. I could reproduce the error given by the installer: cannot stat /cow which is most likely a simple parsing error in grube-probe, which is called from grub-install.

Grub2 used by OpenSuse Leap 15.2 does not have this kind of problem.


This is a description of how to go about installing Ubunto Server.

Install Ubuntu 20.04 Focal Fossa with RAID 1 on two devices

Comment: I have not tried the solution above but based on my experience it will work most likely. I did not try that as it involved the destruction of the existing raid, which I did not want (unless absolutely necessary - and it turned out that it was not necessary at all)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .