2

Was-Working: In Ubuntu 19.10, I was able to switch between my USB headphones and HDMI/DisplayPort based sound output whenever I wanted, and each would work depending on the setting in System Settings -> Sound.

Problem: Since the upgrade to 20.04, while my USB Headphones are plugged in, ALL sound goes through them, even if I select HDMI/DisplayPort as my output device in System Settings -> Sound.

Work-around: If I simply unplug my USB headphones, I can get sound working through DisplayPort as normal. However I don't want to always unplug my headphones.

The way everything is hooked up is, my monitor is connected via DisplayPort to my Nvidia GTX 1070 card, and I have audio speakers (3.5mm jack) hooked to my monitor. If my audio device is set to DisplayPort output it should play through my speakers, as it was doing fine in 19.04.

Nvidia Driver Version: 440.100.

4
  • What about using simultaneous output to all connected devices? There's an option in sound settings (Advanced) - "Add virtual output device for simultaneous output on all local sound cards". IMO best of all worlds - you can disconnect or mute devices as needed. – Nmath Aug 18 '20 at 20:14
  • @Nmath that would be amazing; but I don't see that option or any "Advanced" area. But following the idea I googled it and installed paprefs to get this option. I see the new "virtual" device which says output to X, Y, and Z (all audio devices) but sadly, the USB headphones are still "clobbering" everything else even when I select that simultaneous output device. Perhaps there is something else going on which is auto-muting everything else when the USB headphones are plugged in. – Michael Butler Aug 18 '20 at 20:43
  • have you made sure that the "Default" audio device is set to the simultaneous output, even when the headphones are plugged in? – Nmath Aug 18 '20 at 20:51
  • 1
    @Nmath Yes, I have selected the simultaneous device as the default/chosen one. It still only outputs to headphones when that is selected. However, did some more Googling and got the switching back-and-forth working (not simultaneous output unfortunately, which would be cool). I'll self-post an answer on how – Michael Butler Aug 18 '20 at 20:54
2

I was able to solve this by simply following these steps: Analog and digital audio output at the same time which I'll repeat here:

Specifically add the following to your /etc/pulse/default.pa :

### Load analog device
load-module module-alsa-sink device=hw:0,0
load-module module-combine-sink sink_name=combined
set-default-sink combined

Furthermore, I went ahead and commented out these lines in the same file mentioned above:

### Should be after module-*-restore but before module-*-detect
#load-module module-switch-on-port-available

and

#.ifexists module-switch-on-connect.so
#load-module module-switch-on-connect
#.endif

Which should also prevent auto switching.

Finally I ran:

pulseaudio -k

To have it pick up the changes. After doing this, I was able to select my DisplayPort/HDMI output and have the sound come out of it properly.

1
  • Slight update: The audio switcher in system settings was still working oddly even after doing these steps, so I restarted my system fully, and now the simultaneous audio output actually works, too. A nod to @Nmath for the idea – Michael Butler Aug 18 '20 at 21:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.