2

I followed all of the instructions on downloading the Ubuntu ISO through BitTorrent client web download. I then followed the instructions on creating a USB stick using Rufus and got to the part where I select Boot selection then I hit the Selection menu and the Ubuntu ISO file that I had downloaded using BitTorrent Client download did not show up on my computer.

It only showed (Ubuntu ISO), when I open the File Explorer manually, but not when I use Rufus to open it.

Can anyone help me in figuring out why it's not showing up on Rufus but only shows when I open the File Explorer manually?

3
  • 1
    Maybe the file type isn't ISO because of a bad download, did you check what type of file it is (and I mean by contents, and not file name). tutorials.ubuntu.com/tutorial/tutorial-how-to-verify-ubuntu#0 – guiverc Aug 18 '20 at 3:56
  • 1
    Welcome to Ask Ubuntu. Did you download the ISO from an official Ubuntu site? Is the name of the file ubuntu-20.04.1-desktop-amd64.iso? Confirm Rufus settings look just like this: askubuntu.com/questions/1262073/… – C.S.Cameron Aug 18 '20 at 5:08
  • @guiverc Ubuntu publishes BitTorrent files for most releases at cdimage.ubuntu.com and the benefit of BitTorrent is that the protocol automatically verifies integrity, and generally improves overall download speed as well. This makes it an excellent choice for downloading large files like .ISO -- OP, please try to flash this image using etcher (open source)- it is much more user-friendly for the purposes of creating installation media from an ISO: you only have to make two choices: the source .ISO, and the destination USB Device. – Nmath Aug 21 '20 at 1:05
2
  1. What is the extension of the file you downloaded? Are you sure you really downloaded the .iso and not the .iso.torrent (which is just the torrent metadata that you need to use the download the ISO). Rufus will only list files that have .iso, .img and a small list of other extensions. If your file doesn't have a .iso extension, it will not show up by default in Rufus. You need to be able to tell us what extension your file has if you want to get help.

  2. What is the size of the file you downloaded? If it's less than 2 GB then either it's corrupted or you downloaded the wrong file. You need to be able to tell us the size of the file you downloaded if you want to get help.

  3. Be mindful that, as opposed to File Explorer, Rufus runs with elevated privileges, which means that, in some circumstances, it may not be able to access the same folders or see the same data as the standard user. For instance, if you downloaded the ISO to a network share, then Rufus might not be able to access it.

0

When i first tried this, (I am as yet unsure as to why, BUT, it still may answer above question from another point of view) it was with one particular USB stick. And when i followed, exqactly, Ubuntu's recommendations, and it would'nt show the iso, i scratched, my head, and thought why not try my other one. The other one worked in exactly the way Ubuntu's instructions demonstrated. And mission accomplished.

I did get a little worried,, so websearched, and found a guy suggesting ''In the Boot Selection box, have you selected "Disc or ISO image", which almost threw me.And who knwos, it may wortk. BUT, following Ubuntu's own advice makes more sense to me as they should know.

OPH< in short, it may have been an issue with the style or age of the stick? So try another.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.