I want to try out Wayland from a live USB session of 20.04.1. I tried the steps in https://askubuntu.com/a/988579/428527 which is regarding 17.04 without success (system settings still indicate X11 after following the steps).

How would I go about this?

1 Answer 1


The first thing you need to do, assuming you're already booted into the live instance of Ubuntu, is change the way you login. You can click in the bottom right and 'Show Applications.' Once there, you can enter the word 'users', click on the settings app offered, and disable logging in automatically.

When you're done with that, change the password. It turns out this is mandatory - and perhaps a bug. You'll need to deal with Ubuntu's need for a complex password, so just make sure it's at least 12 characters long, not a dictionary word, and has a mix of numbers and letters. Yes, even in the live instance that's temporary they want a complex password meeting whatever criteria they set.

Next, you want to edit /etc/gdm3/custom.conf and comment out the line that disables Wayland.

sudo nano /etc/gdm3/custom.conf

Find the line:


Change it to:


Make sure to save it, obviously.

Restart gdm3 with:

sudo systemctl restart gdm3

Note: That may log you out, that's fine. If it doesn't automatically, log out manually.

Log back in, but after you click the user, there's an icon in the lower right. It's a gear icon. Click it and choose to Ubuntu on Wayland. Then enter your password and press ENTER.

If everything worked, you're logged in with Wayland.

Now, to verify this...

Press CTRL + ALT + T and open the terminal and enter:


If done correctly, it looks like this:


Good luck!

  • 1
    This worked, thanks! I was almost unable to reproduce it though. I was prevented from creating a password, because I was never allowed to confirm my new password by the absolutely ridiculous password change dialog. Not until I input some arbitrarily complex password that I did not want. No password? Fine. Generated password that's impossible to remember? Fine. A password of my choosing? Not allowed. 🤦‍♂️
    – Andreas
    Aug 17, 2020 at 21:54
  • 1
    @Andreas You just have to not use a common word and throw in some numbers. I chose 'Myuserpass$10817200' or something of that nature - useful just long enough to remember it between logging in and logging out on a VM that was behaving remarkably slowly. Then, the VM didn't want to let me back to the login screen - it kept going blank. Still, it eventually worked. I had a hunch but wanted to confirm it before posting it as an answer. Anyhow, it's now on the site as an answer for anyone else wanting to know. I'll edit the post to remark on password complexity.
    – KGIII
    Aug 17, 2020 at 22:00
  • 1
    I'll accept the answer in a day or two. I see you fixed left → right for the session select button already, so the only thing I have to add is that the password is indeed necessary in order to even get the opportunity to select the session type (i.e. a bug).
    – Andreas
    Aug 18, 2020 at 9:23
  • 1
    +1; When I want this, I install the package gnome-system-tools and use the program users-admin to create a new user with a new password (also in a [persistent] live system). If I remember correctly, it is not that finicky with password.
    – sudodus
    Aug 18, 2020 at 14:12
  • 1
    The live instance was rather demanding with changing the live user's password. I didn't test it extensively, I just made more complex passwords until it worked. I did later come across this, but that doesn't seem to jive with my experience. I needed a fairly long and complicated password, or at least ended up with one. If I get some time, I'll boot to the live instance again and check the password complexity systematically.
    – KGIII
    Aug 18, 2020 at 14:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .