I am trying to setup an encrypted root with a detached header in Ubuntu 20.04

I was able to get it to work successfully in Ubuntu 18.04. I created the file: /etc/initramfs-tools/conf.d/cryptroot with


So I made a similar file in Ubuntu 20.04. But when I enter my password during booting, I get the message:

ERROR: ROOT: cryptsetup failed, bad password or options?

I've tried all sorts of subtle variations and I'm really stuck. Development seems to be going on here but there isn't enough (public?) discussion so I cant understand what's changed.

I checked to confirm that /etc/initramfs-tools/conf.d/cryptroot is still copied across into my initramfs. I don't believe the initramfs is actually reading the cryptroot at all because if I add additional options such as "tries=8" I still only get the default three attempts.

Does /etc/initramfs-tools/conf.d/cryptroot still exist for setting options? Has it been moved somewhere else? Is there a completely different method I should be using now?

Thanks for reading. I hope someone can shed some light on this.


With detached headers the disks don’t usually have a partuuid for crypt to lock on to, full disk anyway which I’m assuming your using for root.

Have you tried aiming your source as /dev/disk/BY-ID/ as that is how mine is set up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.