I used Skype with this command on Ubuntu 11.10:

LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype

But since I upgraded to 12.04 it dosn't work and I can't use my video (Webcam).

I have latest libv4l and my Webcam works with other apps.

How can I fix this?

  • This seems like a bug to me. Skype is supposed to "just work", including video telefonie.
    – gabkdlly
    Jan 8, 2013 at 17:24

2 Answers 2


The path to v4l1compat.so has been changed. So, you should use the command:

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype
  • Im having a similar problem trying to get a Trust webcam to work on a Packard Bell with Ubuntu 12.04 with Skype. Where do I install the above command? Sorry Im very new to Lynx
    – user58169
    Apr 29, 2012 at 11:00
  • 2
    Is there a way to set Skype to launch this way by default?
    – weberc2
    May 14, 2012 at 9:51
  • 1
    Yes there is. I used this tutorial: community.linuxmint.com/tutorial/view/219 and it worked for ubuntu 11.10. In 12.04 the location of the compat lib changed, so you should the above line instead. May 14, 2012 at 11:58
  • These seemed at first to work but I am afraid for me it just does not.After a few years of using these hacks I cannot get this one above to work I am afraid. I am using a logitech quick cam 2500 and when skype starts now and I press the test button I get a fleeting picture and then it freezes. When I tested using another connection there is no video at all. I am getting to the stage when this is being a pain and I would like to be able to help create a solution to this. May 22, 2012 at 8:49
  • For now I will go through all the related webcam/skype older solutions (mine included) and redirect them to the solution above even though it does not work for me. May 22, 2012 at 8:51

First you will need to make sure you have libv4l-0 installed.

If you have installed Ubuntu restricted extras then you should already have it if not open Software Centre and install Ubuntu restricted extras from there.

Once this is done open a Terminal and copy and paste the following command

sudo gedit /usr/share/applications/skype.desktop

After you have provided your password a text editor will open. Line 4 should look like this


Replace with this text

Exec=bash -c 'LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype'

Save and exit the text editor and close the terminal. Now you can open Skype and test your webcam via 'options' then 'video devices'

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .